summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-10-08 14:06:36 -0400
committerCraig Andrews <candrews@gentoo.org>2020-10-08 16:01:07 -0400
commit3ff62013096fd8cbedec45002d9b5e53ca883dcc (patch)
treebc385a16f1fb1af4bd383f15847e0ec0c625252f
parentmate-extra/mate-screensaver: remove consolekit support (diff)
downloadgentoo-3ff62013.tar.gz
gentoo-3ff62013.tar.bz2
gentoo-3ff62013.zip
media-plugins/kodi-peripheral-joystick: 1.7.1 version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--media-plugins/kodi-peripheral-joystick/Manifest1
-rw-r--r--media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-plugins/kodi-peripheral-joystick/Manifest b/media-plugins/kodi-peripheral-joystick/Manifest
index fe853b137ad7..5dbdc5b09f33 100644
--- a/media-plugins/kodi-peripheral-joystick/Manifest
+++ b/media-plugins/kodi-peripheral-joystick/Manifest
@@ -5,3 +5,4 @@ DIST kodi-peripheral-joystick-1.4.9.tar.gz 111161 BLAKE2B bcee8aedff118cbceec050
DIST kodi-peripheral-joystick-1.6.0.tar.gz 117163 BLAKE2B 24e6eb1b4b4310fc3fc452a719094cdaac7caf7ef4825add4a9bcde453044e5a352b859b0c247fa445bde5554a3b82e40c65f185adc524f855140126716a3e27 SHA512 9fd11af0e75a80cfd1086caf29213616a441c0f8c5066ab2d54dac94603240c5f13af9048ae0691f6bd34511ac36c8cf478cdd6cd179ef97f282ae82f932e0fe
DIST kodi-peripheral-joystick-1.6.1.tar.gz 117588 BLAKE2B c117990d6dc90ff53f4d23e08288df1cfe2fa0f685498a9f9630a07e6ee36207af3c2ed6faf81746e06bdcd94674cd89d97fe6ff75ea5263754c4eba10498605 SHA512 3907fea59d1919f9580e17e01b672aa525b106cb126dc6e7c873fe20b8dd68f395f39fb52ae08a02206a1c301523cd9a2b2f67076cb5e6c4b582d46800a892c7
DIST kodi-peripheral-joystick-1.7.0.tar.gz 117000 BLAKE2B a13cf86805afc77c6178a69fb735fa4544fbc0befb30c43e92d07a695416d1c0006a2227e46c91784c139e7ea205f9653b4f4802bfd734f36c7db9a69782d4ed SHA512 d6c837b28e907376b88e84b37cb9e2f04d96cd97db33f53165c1771087317682409057457596e007410c4dce0b6442551dd922d8a2c4841187e48457ec7ce340
+DIST kodi-peripheral-joystick-1.7.1.tar.gz 115217 BLAKE2B b349a52fd756cc55d0fd08d78c2a6c81f6a34e1e5bc9d4e02904a904f26cddfae373ba3532505e736300d31a49d344c2a77b06a92da56a2641505dae0296a843 SHA512 38c53ccd9815212eb51154faaa8073507457a6f7c68d4d472f7c4e4e3a5342cfc085a75a2d3022475d57df08ac0e800406d24484106e64316957772f41235d5c
diff --git a/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.1.ebuild b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.1.ebuild
new file mode 100644
index 000000000000..b29f362fab00
--- /dev/null
+++ b/media-plugins/kodi-peripheral-joystick/kodi-peripheral-joystick-1.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Libretro compatibility layer for the Kodi Game API"
+HOMEPAGE="https://github.com/xbmc/peripheral.joystick"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_BRANCH="Matrix"
+ EGIT_REPO_URI="https://github.com/xbmc/peripheral.joystick.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ CODENAME="Matrix"
+ SRC_URI="https://github.com/xbmc/peripheral.joystick/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/peripheral.joystick-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ dev-libs/libpcre
+ dev-libs/tinyxml
+ "
+RDEPEND="
+ ${DEPEND}
+ "