summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-02-15 10:14:35 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-02-15 10:14:56 -0600
commit40014ac3c68185a17d4d9a8efebf8b3d40d8e152 (patch)
treee5330af0eddd2d16f1731ee01e2e97e9bd69b8bf
parentdev-python/oslo-cache: 1.30.1 stable amd64 and x86 with cleanup (diff)
downloadgentoo-40014ac3.tar.gz
gentoo-40014ac3.tar.bz2
gentoo-40014ac3.zip
dev-python/oslo-service: 1.31.7 stable amd64/x86 with cleanup
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/oslo-service/Manifest2
-rw-r--r--dev-python/oslo-service/oslo-service-1.29.0.ebuild61
-rw-r--r--dev-python/oslo-service/oslo-service-1.31.5.ebuild63
-rw-r--r--dev-python/oslo-service/oslo-service-1.31.7.ebuild2
4 files changed, 1 insertions, 127 deletions
diff --git a/dev-python/oslo-service/Manifest b/dev-python/oslo-service/Manifest
index 4175338fbfdb..f2e0af20b6a3 100644
--- a/dev-python/oslo-service/Manifest
+++ b/dev-python/oslo-service/Manifest
@@ -1,3 +1 @@
-DIST oslo.service-1.29.0.tar.gz 74957 BLAKE2B b56869cb28704718952c5e151eaf0442b1a4295b8e25a422d91baa241a990d031cd408474e44bd5ea2af2b7451e0c13ec491ed4c2ccf0b07c78b65a81bec4527 SHA512 84f1b8e6abc7c8c95433da53b1a1992570695b80e182f5cb7d87ab394857d8d47c0ef0528b7a45221c897eb4c5c13112d86b8a929efc2988d22844a4c712a340
-DIST oslo.service-1.31.5.tar.gz 71865 BLAKE2B 2ad5ff5124e1b33a216510d39e7d37f3371257281cda9ebe0263a3dc741762d8c737478772cb89000a01bcbb7d9647a3cc3bbeaa62949f4957d1f2eb7ff0ba1e SHA512 9c6ebcfc9683601bfd4a54dfa8eeb3d687ea813a5081550092845350fb178fb9f609ff9f3caca6f0cd48ca6280ec71b4587741ed5a836ca38bbc6958aa521fb3
DIST oslo.service-1.31.7.tar.gz 72069 BLAKE2B 8a40608ba3b4ab8c78cc48f89607af5db3e493aaec48e4b33d917fd5ea32478dc04a0ccb2f1aec524acc900a13d9880d8bd51e49bd3b2eab787d7b7c55872e47 SHA512 18bd558cbbf67441438f62a212ca61affd625597a02cbe8948bf055e61887a0e1b21dfc18e7450ec21951377daabcda8e5e7f57b39f5dcaa1b1d635df13f8e21
diff --git a/dev-python/oslo-service/oslo-service-1.29.0.ebuild b/dev-python/oslo-service/oslo-service-1.29.0.ebuild
deleted file mode 100644
index 6f1036b88463..000000000000
--- a/dev-python/oslo-service/oslo-service-1.29.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for running OpenStack services"
-HOMEPAGE="https://pypi.org/project/oslo.service/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.service/oslo.service-${PV}.tar.gz"
-S="${WORKDIR}/oslo.service-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
- >=dev-python/doc8-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
- <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.4.10[${PYTHON_USEDEP}]
- >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-concurrency-3.20.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
- >=dev-python/paste-2.0.2[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests tests/ || die "test failed under ${EPYTHON}"
-}
diff --git a/dev-python/oslo-service/oslo-service-1.31.5.ebuild b/dev-python/oslo-service/oslo-service-1.31.5.ebuild
deleted file mode 100644
index 51d7ec7608e2..000000000000
--- a/dev-python/oslo-service/oslo-service-1.31.5.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for running OpenStack services"
-HOMEPAGE="https://pypi.org/project/oslo.service/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.service/oslo.service-${PV}.tar.gz"
-S="${WORKDIR}/oslo.service-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
- >=dev-python/doc8-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.4.10[${PYTHON_USEDEP}]
- >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-concurrency-3.25.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
- >=dev-python/paste-2.0.2[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests tests/ || die "test failed under ${EPYTHON}"
-}
diff --git a/dev-python/oslo-service/oslo-service-1.31.7.ebuild b/dev-python/oslo-service/oslo-service-1.31.7.ebuild
index 2a0093adb6f1..1826f7701238 100644
--- a/dev-python/oslo-service/oslo-service-1.31.7.ebuild
+++ b/dev-python/oslo-service/oslo-service-1.31.7.ebuild
@@ -13,7 +13,7 @@ S="${WORKDIR}/oslo.service-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="test"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]