summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-09 07:46:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-09 08:30:51 +0100
commit4007d1efbc8a97568db7002016ea66f4c4310b99 (patch)
tree36f3735af93399a59c28d0df6a3bbfe654a68562
parentdev-python/jc: Bump to 1.17.4 (diff)
downloadgentoo-4007d1ef.tar.gz
gentoo-4007d1ef.tar.bz2
gentoo-4007d1ef.zip
dev-python/colorclass: Bump to 2.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/colorclass/Manifest1
-rw-r--r--dev-python/colorclass/colorclass-2.2.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/colorclass/Manifest b/dev-python/colorclass/Manifest
index eb298177c197..a1c3916f4544 100644
--- a/dev-python/colorclass/Manifest
+++ b/dev-python/colorclass/Manifest
@@ -1 +1,2 @@
DIST colorclass-2.2.0.gh.tar.gz 486151 BLAKE2B d8f4c9e826cf284df47bf2aac4da71f448818858e2383b331b5bba791d9db3c5c11d5aff74b3eb740e657914137b2b74b217854ab589806a22a0ff6697cbde1c SHA512 c627cdf6abdb5a60e9ecc1fb3b669898edc027fdc3f8cde31be2e10402ee308c2067fcd50d1228759e93fc58c521b7fc12e6b259233a17cf99f55cda26279fed
+DIST colorclass-2.2.2.gh.tar.gz 490884 BLAKE2B e03c1a7091c133cea67c595363029121083d9a9d70a27f5803b20bb810b105ea9cb95aa68114ba98526b8a3b0e8365eadd7b375443215a5e0b636f0bd4cce632 SHA512 c38b58d4122e794654a8ac71adb2be0fb679eb10bd70c9d8f5dee06b3c978c1530bb3fb8fd6530d88aa35311a46a2590b709e4dcc6e3a81d14b90bf8cb74ebc1
diff --git a/dev-python/colorclass/colorclass-2.2.2.ebuild b/dev-python/colorclass/colorclass-2.2.2.ebuild
new file mode 100644
index 000000000000..31cca6e7e360
--- /dev/null
+++ b/dev-python/colorclass/colorclass-2.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Colorful worry-free console applications for multiple platforms"
+HOMEPAGE="
+ https://pypi.org/project/colorclass/
+ https://github.com/matthewdeanmartin/colorclass"
+SRC_URI="
+ https://github.com/matthewdeanmartin/colorclass/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/docopt[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # workaround pp2sp complaining about unsupported exclude,
+ # even though it's empty (fix will be included in pp2sp-22)
+ sed -i -e 's:^exclude:empty-&:' pyproject.toml || die
+ distutils-r1_src_prepare
+}