summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-21 23:55:44 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-22 01:14:27 -0500
commit40176126265d224746f6fc5364f9597a6df806a8 (patch)
tree9cfd23fc71cb6b7006106eb2b6a8982358ad85ce
parentdev-qt/qtsvg: drop 6.6.1 (diff)
downloadgentoo-40176126265d224746f6fc5364f9597a6df806a8.tar.gz
gentoo-40176126265d224746f6fc5364f9597a6df806a8.tar.bz2
gentoo-40176126265d224746f6fc5364f9597a6df806a8.zip
dev-qt/qttools: drop 6.6.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-qt/qttools/Manifest1
-rw-r--r--dev-qt/qttools/qttools-6.6.1.ebuild148
2 files changed, 0 insertions, 149 deletions
diff --git a/dev-qt/qttools/Manifest b/dev-qt/qttools/Manifest
index f432c251ad0b..135f5bcd15f7 100644
--- a/dev-qt/qttools/Manifest
+++ b/dev-qt/qttools/Manifest
@@ -1,2 +1 @@
-DIST qttools-everywhere-src-6.6.1.tar.xz 8583536 BLAKE2B c52fd1643f925909c2e5f677574ee202c0de5b810e9ca603f27511b123ce570c4bbf4aa3efd2c4347dace91d92546f5cb90e7ca783b7182369d13dcdbdac2db4 SHA512 7f7bfaf7f01a5374f711c20113e9461b83a6f908b48c7b3f662f8821a70ef0c792f040f2e8e62a570fec06df2329fe5eb953c680424262b3678ab283045e6909
DIST qttools-everywhere-src-6.6.2.tar.xz 8594492 BLAKE2B 17d4385df9c0a70e8c3c135bd56f835c80d98008694331a2c2e8381b1489aafd56ca140ad300d868bdf795742326771358fc18f9c4e27b9aceb937a59536ddd9 SHA512 bf8d7fc92768b2a4992cef021576b1a6ed1405995ab18113db22c72f9e159b38012ff98d797b2a9578cc82527dc51fae92605a5e6a94fdeecd7e0da95509ce90
diff --git a/dev-qt/qttools/qttools-6.6.1.ebuild b/dev-qt/qttools/qttools-6.6.1.ebuild
deleted file mode 100644
index ef4f14675dbd..000000000000
--- a/dev-qt/qttools/qttools-6.6.1.ebuild
+++ /dev/null
@@ -1,148 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit desktop llvm optfeature qt6-build
-
-DESCRIPTION="Qt Tools Collection"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-IUSE="
- +assistant clang designer distancefieldgenerator gles2-only
- +linguist opengl pixeltool qdbus qdoc qml qtattributionsscanner
- qtdiag qtplugininfo vulkan +widgets zstd
-"
-# note that some tools do not *require* widgets but will skip a sub-tool
-# if not enabled (e.g. linguist gives lrelease but not the GUI linguist6)
-REQUIRED_USE="
- assistant? ( widgets )
- designer? ( qml widgets )
- distancefieldgenerator? ( qml widgets )
- pixeltool? ( widgets )
- qdoc? ( clang qml )
-"
-
-# behaves very badly when qttools is not already installed, also
-# other more minor issues (clang tests flaky depending on version,
-# and 3rdparty/ tries to FetchContent gtest)
-RESTRICT="test"
-
-LLVM_MAX_SLOT=17
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network,widgets?]
- assistant? ( ~dev-qt/qtbase-${PV}:6[sql,sqlite] )
- clang? ( <sys-devel/clang-$((LLVM_MAX_SLOT+1)):= )
- designer? (
- ~dev-qt/qtbase-${PV}:6[xml,zstd=]
- zstd? ( app-arch/zstd:= )
- )
- qdbus? ( ~dev-qt/qtbase-${PV}:6[dbus,xml] )
- qml? ( ~dev-qt/qtdeclarative-${PV}:6[widgets?] )
- qtdiag? ( ~dev-qt/qtbase-${PV}:6[gles2-only=,vulkan=] )
- widgets? ( ~dev-qt/qtbase-${PV}:6[opengl=] )
-"
-DEPEND="
- ${RDEPEND}
- qtdiag? (
- vulkan? ( dev-util/vulkan-headers )
- )
-"
-
-llvm_check_deps() {
- has_version -d "sys-devel/clang:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- use clang && llvm_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- # prevent the clang test as it can abort due to bug #916098
- $(cmake_use_find_package clang WrapLibClang)
- $(cmake_use_find_package qml Qt6Qml)
- $(cmake_use_find_package widgets Qt6Widgets)
- $(qt_feature assistant)
- $(qt_feature clang)
- $(qt_feature designer)
- $(qt_feature distancefieldgenerator)
- $(qt_feature linguist)
- $(qt_feature pixeltool)
- $(qt_feature qdbus)
- $(qt_feature qdoc)
- $(qt_feature qtattributionsscanner)
- $(qt_feature qtdiag)
- $(qt_feature qtplugininfo)
-
- # TODO?: package litehtml, but support for latest releases seem
- # to lag behind and bundled may work out better for now
- # https://github.com/litehtml/litehtml/issues/266
- $(usev assistant -DCMAKE_DISABLE_FIND_PACKAGE_litehtml=ON)
- )
-
- qt6-build_src_configure
-}
-
-src_install() {
- qt6-build_src_install
-
- if use widgets; then #914766
- use designer || use distancefieldgenerator || use pixeltool &&
- newicon src/designer/src/designer/images/designer.png designer6.png
-
- if use assistant; then
- make_desktop_entry assistant6 'Qt 6 Assistant' assistant6 \
- 'Qt;Development;Documentation' \
- 'Comment=Tool for viewing online documentation in Qt help file format'
- newicon src/assistant/assistant/images/assistant-128.png assistant6.png
- fi
-
- if use designer; then
- make_desktop_entry designer6 'Qt 6 Designer' designer6 \
- 'Qt;Development;GUIDesigner' \
- 'Comment=WYSIWYG tool for designing and building graphical user interfaces with QtWidgets'
- fi
-
- if use distancefieldgenerator; then
- # no icon, sharing with designer which fits letter-wise
- make_desktop_entry qdistancefieldgenerator6 'Qt 6 Distance Field Generator' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for pregenerating the font cache of Qt applications'
- fi
-
- if use linguist; then
- make_desktop_entry linguist6 'Qt 6 Linguist' linguist6 \
- 'Qt;Development;Translation' \
- 'Comment=Tool for translating Qt applications'
- newicon src/linguist/linguist/images/icons/linguist-128-32.png linguist6.png
- fi
-
- if use pixeltool; then
- # no icon, not fitting but share with designer for now
- make_desktop_entry pixeltool6 'Qt 6 Pixel Tool' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for zooming in the desktop area pointed by the cursor'
- fi
-
- if use qdbus; then
- make_desktop_entry qdbusviewer6 'Qt 6 QDBusViewer' qdbusviewer6 \
- 'Qt;Development' \
- 'Comment=Tool that lets introspect D-Bus objects and messages'
- newicon src/qdbus/qdbusviewer/images/qdbusviewer-128.png qdbusviewer6.png
- fi
-
- # hack: make_destop_entry does not support overriding DESCRIPTION
- find "${ED}" -type f -name "*.desktop" \
- -exec sed -i "/^Comment=${DESCRIPTION}/d" -- {} + || die
- fi
-}
-
-pkg_postinst() {
- use assistant &&
- optfeature "Qt documentation viewable in assistant" \
- 'dev-qt/qt-docs:6[qch]' #602296
-}