summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-17 17:14:39 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-17 17:54:57 -0400
commit402ebf4c2ee3809a6fc397755986fa340ec856df (patch)
tree53a467ffaee9276426094f85e29cb0e900fceba2
parentnet-vpn/networkmanager-pptp: Drop old versions (diff)
downloadgentoo-402ebf4c2ee3809a6fc397755986fa340ec856df.tar.gz
gentoo-402ebf4c2ee3809a6fc397755986fa340ec856df.tar.bz2
gentoo-402ebf4c2ee3809a6fc397755986fa340ec856df.zip
sci-geosciences/gnome-maps: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sci-geosciences/gnome-maps/Manifest2
-rw-r--r--sci-geosciences/gnome-maps/files/43.0-tests-timeTest-Fix-tests-for-time-formats-with-diffe.patch58
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-43.4.ebuild53
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-44.0.ebuild49
4 files changed, 0 insertions, 162 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 7fddd89fa8cc..7afecc518b98 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,3 +1 @@
-DIST gnome-maps-43.4.tar.xz 2335020 BLAKE2B 267b4a2a1c8273fdcdccd7f2b385b2c95aa8903d1f5e117affc2174c873931f01cba6d17bfcabd949eb91fbf960469517569a80acd8ecaa45de9a181a7cece9a SHA512 16efd035a940e5ffad6dbbd7d8e527c56fb088211c41d130c0441ae321ea89f3a60524a39dcc5de5bc1caaee408e0eb0fda504471002876b4f3550759939568f
-DIST gnome-maps-44.0.tar.xz 2349928 BLAKE2B 4c2e45f03554a4ef5b34e1dc932764ab96cbf535f305dc8a1504823986d7b4a5b78ab854dd6beea19f7dde168dfdc9fa8874fa06a858db6bf7844e1bdf5b14df SHA512 aa52446c273ac5b8603b5fd266e1e24c920821cd22ae441e41067bae6ed7753e47f57f14fd6a05b0682d3b0f6bfe22fe5e9da26d983812fdb0f419fea21cbe4a
DIST gnome-maps-44.1.tar.xz 2349152 BLAKE2B e544427972f98d13c5c072c234006c081fc000048956cdd795f47225bc73771d655f048bd3ca7d2478f9afd23d50b6f26df95a08ec24b92c1d80a2280a9d2f60 SHA512 918a490491b86aa2648dae844dd910be5e4dff339544a6286d35c341bb11acfa1587de04fe2f2b3aff46c57c4175fc0bad50c28a253ffea8bacf274c0ca42f72
diff --git a/sci-geosciences/gnome-maps/files/43.0-tests-timeTest-Fix-tests-for-time-formats-with-diffe.patch b/sci-geosciences/gnome-maps/files/43.0-tests-timeTest-Fix-tests-for-time-formats-with-diffe.patch
deleted file mode 100644
index 95891953a30c..000000000000
--- a/sci-geosciences/gnome-maps/files/43.0-tests-timeTest-Fix-tests-for-time-formats-with-diffe.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From bec3d2f26de1b3a8c8b7e603f6d6a46c853426fa Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Pablo=20Correa=20G=C3=B3mez?= <ablocorrea@hotmail.com>
-Date: Fri, 28 Oct 2022 01:05:28 +0200
-Subject: [PATCH] tests/timeTest: Fix tests for time formats with different
- kind of spaces
-
-Time.format does not warranty the character used for spaces, neither
-that it will not introduce preceding byte order marks. Solve it by
-comparing inclusion of the data and that it finishes with AM or PM.
-
-Closes #506
----
- tests/timeTest.js | 15 ++++++++++-----
- 1 file changed, 10 insertions(+), 5 deletions(-)
-
-diff --git a/tests/timeTest.js b/tests/timeTest.js
-index 96803f2f..d025e8e8 100644
---- a/tests/timeTest.js
-+++ b/tests/timeTest.js
-@@ -23,6 +23,11 @@ const JsUnit = imports.jsUnit;
-
- import * as Time from './time.js';
-
-+function compare12HourTime(format, hoursMinutes, AMPM) {
-+ JsUnit.assertTrue(format.includes(hoursMinutes));
-+ JsUnit.assertTrue(format.endsWith(AMPM));
-+}
-+
- function formatTimeWithTZOffsetTest() {
- // mock to always use 24 hour format
- Time._setIs12HourFunction(() => { return false; });
-@@ -35,8 +40,8 @@ function formatTimeWithTZOffsetTest() {
- // mock to always use 12 hour format
- Time._setIs12HourFunction(() => { return true; });
-
-- JsUnit.assertEquals('10:54 PM',
-- Time.formatTimeWithTZOffset(1607982864000, 3600000));
-+ compare12HourTime(Time.formatTimeWithTZOffset(1607982864000, 3600000),
-+ '10:54', 'PM');
- }
-
- function formatTimeFromHoursAndMinsTest() {
-@@ -50,9 +55,9 @@ function formatTimeFromHoursAndMinsTest() {
- // mock to always use 12 hour format
- Time._setIs12HourFunction(() => { return true; });
-
-- JsUnit.assertEquals('12:34 PM', Time.formatTimeFromHoursAndMins(12, 34));
-- JsUnit.assertEquals('12:00 AM', Time.formatTimeFromHoursAndMins(24, 0));
-- JsUnit.assertEquals('12:01 PM', Time.formatTimeFromHoursAndMins(12, 1));
-+ compare12HourTime(Time.formatTimeFromHoursAndMins(12, 34), '12:34', 'PM');
-+ compare12HourTime(Time.formatTimeFromHoursAndMins(24, 0), '12:00', 'AM');
-+ compare12HourTime(Time.formatTimeFromHoursAndMins(12, 1), '12:01', 'PM');
- }
-
- formatTimeWithTZOffsetTest();
---
-2.37.4
-
diff --git a/sci-geosciences/gnome-maps/gnome-maps-43.4.ebuild b/sci-geosciences/gnome-maps/gnome-maps-43.4.ebuild
deleted file mode 100644
index 258e281fe40b..000000000000
--- a/sci-geosciences/gnome-maps/gnome-maps-43.4.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit gnome.org gnome2-utils meson xdg
-
-DESCRIPTION="A map application for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
-
-LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-
-# Pure introspection dependencies found by grepping imports in ${S}
-RDEPEND="
- >=dev-libs/glib-2.66.0:2
- >=dev-libs/gjs-1.69.2
- >=dev-libs/gobject-introspection-0.10.1:=
- gui-libs/gtk:4[introspection]
- >=app-misc/geoclue-0.12.99:2.0[introspection]
- >=gui-libs/libadwaita-1.0:1[introspection]
- >=dev-libs/libgweather-4.2.0:4=[introspection]
- >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
- >=media-libs/libshumate-1.0:1.0=[introspection]
- dev-libs/libxml2:2
- >=net-libs/rest-0.9.1:1.0[introspection]
-
- app-crypt/libsecret[introspection]
- media-libs/graphene[introspection]
- net-libs/libsoup:3.0[introspection]
- x11-libs/pango[introspection]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-util/glib-utils
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}"/43.0-tests-timeTest-Fix-tests-for-time-formats-with-diffe.patch
-)
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}
diff --git a/sci-geosciences/gnome-maps/gnome-maps-44.0.ebuild b/sci-geosciences/gnome-maps/gnome-maps-44.0.ebuild
deleted file mode 100644
index b7701c61f77d..000000000000
--- a/sci-geosciences/gnome-maps/gnome-maps-44.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit gnome.org gnome2-utils meson xdg
-
-DESCRIPTION="A map application for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
-
-LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
-
-# Pure introspection dependencies found by grepping imports in ${S}
-RDEPEND="
- >=dev-libs/glib-2.66.0:2
- >=dev-libs/gjs-1.69.2
- >=dev-libs/gobject-introspection-0.10.1:=
- gui-libs/gtk:4[introspection]
- >=app-misc/geoclue-0.12.99:2.0[introspection]
- >=gui-libs/libadwaita-1.0:1[introspection]
- >=dev-libs/libgweather-4.2.0:4=[introspection]
- >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
- >=media-libs/libshumate-1.0:1.0=[introspection]
- dev-libs/libxml2:2
- >=net-libs/rest-0.9.1:1.0[introspection]
-
- app-crypt/libsecret[introspection]
- media-libs/graphene[introspection]
- net-libs/libsoup:3.0[introspection]
- x11-libs/pango[introspection]
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-util/glib-utils
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-pkg_postinst() {
- xdg_pkg_postinst
- gnome2_schemas_update
-}
-
-pkg_postrm() {
- xdg_pkg_postrm
- gnome2_schemas_update
-}