summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-04 00:26:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-04 01:43:17 +0100
commit402fb92fcb1eaf9cb5e76d3834621451b3637e84 (patch)
tree60863a68df813c5f2033f44e115eccba64cc5644
parentdev-libs/double-conversion: 3.0.3 version bump (diff)
downloadgentoo-402fb92f.tar.gz
gentoo-402fb92f.tar.bz2
gentoo-402fb92f.zip
dev-libs/double-conversion: Drop 3.0.0-r1
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/double-conversion/double-conversion-3.0.0-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-libs/double-conversion/double-conversion-3.0.0-r1.ebuild b/dev-libs/double-conversion/double-conversion-3.0.0-r1.ebuild
deleted file mode 100644
index 786bdf2fd13a..000000000000
--- a/dev-libs/double-conversion/double-conversion-3.0.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils multibuild
-
-DESCRIPTION="Binary-decimal and decimal-binary conversion routines for IEEE doubles"
-HOMEPAGE="https://github.com/google/double-conversion"
-SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/1"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-IUSE="static-libs test"
-
-pkg_setup() {
- MULTIBUILD_VARIANTS=( shared $(usev static-libs) )
-}
-
-src_configure() {
- myconfigure() {
- local mycmakeargs=( -DBUILD_TESTING=$(usex test) )
- if [[ ${MULTIBUILD_VARIANT} = shared ]]; then
- mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- fi
- if [[ ${MULTIBUILD_VARIANT} = static-libs ]]; then
- mycmakeargs+=( -DBUILD_SHARED_LIBS=OFF )
- fi
-
- cmake-utils_src_configure
- }
-
- multibuild_foreach_variant myconfigure
-}
-
-src_compile() {
- multibuild_foreach_variant cmake-utils_src_compile
-}
-
-src_test() {
- [[ ${MULTIBUILD_VARIANT} = shared ]] && cmake-utils_src_test
-}
-
-src_install() {
- myinstall() {
- [[ ${MULTIBUILD_VARIANT} = shared ]] && cmake-utils_src_install
- [[ ${MULTIBUILD_VARIANT} = static-libs ]] && \
- dolib ${BUILD_DIR}/double-conversion/libdouble-conversion.a
- }
-
- multibuild_foreach_variant myinstall
-}