summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-31 13:04:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-31 13:33:01 +0200
commit4049f427d8f160f0ea335a15a2224ae6bc22db32 (patch)
tree9df0650ac8fe9eb930042a51cc2b04d2efaf6e0b
parentdev-python/libcloud: Bump to 3.5.1 (diff)
downloadgentoo-4049f427d8f160f0ea335a15a2224ae6bc22db32.tar.gz
gentoo-4049f427d8f160f0ea335a15a2224ae6bc22db32.tar.bz2
gentoo-4049f427d8f160f0ea335a15a2224ae6bc22db32.zip
dev-python/doc8: Bump to 0.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/doc8/Manifest1
-rw-r--r--dev-python/doc8/doc8-0.11.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/doc8/Manifest b/dev-python/doc8/Manifest
index f5039848a202..af1dc3de8868 100644
--- a/dev-python/doc8/Manifest
+++ b/dev-python/doc8/Manifest
@@ -1 +1,2 @@
+DIST doc8-0.11.0.tar.gz 25540 BLAKE2B 4ccfd741da44206e12ec0adcc2155534225363fdd034dfef259b425fc862bfcb62eea691bc86bb39d0fc26fda036956be4f60eaa2214a8eaf6ec1086fa83ec1d SHA512 9a8b57bfe21dcc7302fbdcb9b5f1592c7449b43d4475622926b794a0e9041e85ae7806990517e911348f78f5871133983ec0feab13cea3ccca7e75449e519351
DIST doc8-0.9.1.tar.gz 31122 BLAKE2B 84708d05414fe1545558910d0d74ae9612091500efb1880062910b395f1244c6edb1fe1c95ff97a177fcbb4127fcbc4b819a749f90c8384c0c23e9041af12b25 SHA512 058403a808ec2d55cf732c8eb0e28f6902c935a6fe0fd4e3ce1a11088888f32875a416adf478b81192948ebd581548b2d1591581222f1e841e97777980a80d69
diff --git a/dev-python/doc8/doc8-0.11.0.ebuild b/dev-python/doc8/doc8-0.11.0.ebuild
new file mode 100644
index 000000000000..4f9d8a2a0054
--- /dev/null
+++ b/dev-python/doc8/doc8-0.11.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Style checker for Sphinx (or other) RST documentation"
+HOMEPAGE="
+ https://pypi.org/project/doc8/
+ https://github.com/pycqa/doc8/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/restructuredtext-lint-0.7[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ test? (
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s src
+}
+
+pkg_postinst() {
+ optfeature "checking pyproject.toml projects" dev-python/toml
+}