summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 15:25:37 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 20:37:55 +0100
commit405a8c81c021418a7e691a67c02f3af472caadac (patch)
tree34afc8fb44695d565b5ccdae811b32c7dd913416
parentprofiles/package.mask: net-fs/openafs-kernel is removed from the tree (diff)
downloadgentoo-405a8c81c021418a7e691a67c02f3af472caadac.tar.gz
gentoo-405a8c81c021418a7e691a67c02f3af472caadac.tar.bz2
gentoo-405a8c81c021418a7e691a67c02f3af472caadac.zip
dev-python/sympy: Bump to 1.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sympy/Manifest1
-rw-r--r--dev-python/sympy/sympy-1.7.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/sympy/Manifest b/dev-python/sympy/Manifest
index 6b9a378ad3ec..aeec1a4ad9af 100644
--- a/dev-python/sympy/Manifest
+++ b/dev-python/sympy/Manifest
@@ -1,2 +1,3 @@
DIST sympy-1.6.2.tar.gz 6811705 BLAKE2B 4cd894d28bedc986acc8ef67aa60f82e0899c2ed028658a8f340d7538b890e0ed380b3614a464eb58d71873b29b0795508b4556bb8115bf0c108336ef1e4cca3 SHA512 e16a1d85aba438e4248bac48a163ea1827e2cee57c28f7670ed19cc69d4c08d6796d62f79d245e269d75765b8f7ff4f4ca2841f98534e136ceeb5d3f7a5d252a
+DIST sympy-1.7.tar.gz 6969594 BLAKE2B c4ebd395e50f589dba2d01bf50a1a9cd7fb34e95e2b8632a64df5fe1a6625889c4e161b8a22aa815857cc3eb0d502f03ec8d9de694f369aaca7e573a2fab03ee SHA512 f7bdaff7432436dc888e56d4b56d023c8da5cfb54dfa6955cf7999acceedfd5175f910fb9b3c5776145f3dc3036f78e66813cdba4201be854dfa2c5c9f4e9f4d
DIST sympy-1.7rc1.tar.gz 6969788 BLAKE2B d7429aa6fde9943926cc14d77fe71e94b50e2329e56854d6e59ab6d2a09f659458d6baf18f36ed0b33e5add5fb0e38064730e4603e86f8edb8106683ff8063ab SHA512 7ffa8254ceeb0cd68c03503aa7ac662f2f8fe07aec0d3e6dc0afdca4e14b674e6b9db2feea79f272b9fae398d7c9edf49ac235526b5949262ca6ea8e412b9029
diff --git a/dev-python/sympy/sympy-1.7.ebuild b/dev-python/sympy/sympy-1.7.ebuild
new file mode 100644
index 000000000000..fd39817141d0
--- /dev/null
+++ b/dev-python/sympy/sympy-1.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Computer Algebra System in pure Python"
+HOMEPAGE="https://sympy.org"
+SRC_URI="https://github.com/sympy/sympy/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
+ ipython? ( dev-python/ipython[${PYTHON_USEDEP}] )
+ latex? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsextra
+ png? ( app-text/dvipng )
+ pdf? ( app-text/ghostscript-gpl )
+ )
+ mathml? ( dev-libs/libxml2:2[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+ pyglet? ( dev-python/pyglet[${PYTHON_USEDEP}] )
+ symengine? ( dev-python/symengine[${PYTHON_USEDEP}] )
+ texmacs? ( app-office/texmacs )
+ theano? ( dev-python/theano[${PYTHON_USEDEP}] )
+"
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" setup.py test || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS README.md )
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+
+ if use texmacs; then
+ exeinto /usr/libexec/TeXmacs/bin/
+ doexe data/TeXmacs/bin/tm_sympy
+ insinto /usr/share/TeXmacs/plugins/sympy/
+ doins -r data/TeXmacs/progs
+ fi
+}