summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 06:34:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 07:16:20 +0200
commit405fc591228e03eb9eec6696e7006738a377494d (patch)
tree226464aa60c7809abc221d2044f8fe373d58f3c1
parentdev-python/pytest-env: Bump to 1.1.0 (diff)
downloadgentoo-405fc591228e03eb9eec6696e7006738a377494d.tar.gz
gentoo-405fc591228e03eb9eec6696e7006738a377494d.tar.bz2
gentoo-405fc591228e03eb9eec6696e7006738a377494d.zip
dev-python/jc: Bump to 1.23.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jc/Manifest1
-rw-r--r--dev-python/jc/jc-1.23.6.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/jc/Manifest b/dev-python/jc/Manifest
index 3be05819f97e..d72bf249ab37 100644
--- a/dev-python/jc/Manifest
+++ b/dev-python/jc/Manifest
@@ -1,2 +1,3 @@
DIST jc-1.23.4.gh.tar.gz 12920166 BLAKE2B 3980f0564121362028c03fcdab653ef449bd6706eded19276cdcad7a5a18c819ae89fb5d82157af7add190203af2a9900d185aa54b0620357e6b639934bee0bf SHA512 e757e06e8eb740c85df03a92184fc285f35806365fffd4b8459e73fe54d7fcc4e476a4886daa713cd0fe1c5712aa867478a339eb208b55ef92e88945c4ae63a9
DIST jc-1.23.5.gh.tar.gz 12938443 BLAKE2B 4234adb9eb402bc7f86abb47831b4803de71d1c193625ca20866d0cf53e9f7a70af2d8e1ec2b3a3414f2df7977a51e72dad95dc893e0e49f7d1e97a590f5a40b SHA512 595f50041b08c3b1e3d6dd65b4b0ed00e381860c87f3a79cf674f675f7c1aba56317b2cab8cac384cbbc6e36d1fa2144624e588fbb004c669d9998cf765c4ff8
+DIST jc-1.23.6.gh.tar.gz 12948974 BLAKE2B be4e0468a18859080e0d6536961a6c6cd8c43384c174437c12e6bcae1a0e323297c45b469bb8b5ab7ef02cb69f225a817effbccc48bb0c1ac934d11b227707cd SHA512 a79a289f9d30dc8827f1276e34dcd80af60800b5b4b4eb8d0c4bfbea4a996e932efe2242adad2e1b58cbfb4f1ff8a0bcc591df5c9d630226201d347d0d8d9c47
diff --git a/dev-python/jc/jc-1.23.6.ebuild b/dev-python/jc/jc-1.23.6.ebuild
new file mode 100644
index 000000000000..c000229f5977
--- /dev/null
+++ b/dev-python/jc/jc-1.23.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="
+ https://github.com/kellyjonbrazil/jc/
+ https://pypi.org/project/jc/
+"
+# no tests in sdist, as of 1.23.2
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest