summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-18 11:03:33 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-18 11:32:10 +0200
commit408c4a56b255f6f83d639c2b585b97145e971566 (patch)
tree6f480660ef471e381ecf7109c11933455d0b77b3
parentnet-misc/wget: disable libiconv for uclibc, bug #587620 (diff)
downloadgentoo-408c4a56b255f6f83d639c2b585b97145e971566.tar.gz
gentoo-408c4a56b255f6f83d639c2b585b97145e971566.tar.bz2
gentoo-408c4a56b255f6f83d639c2b585b97145e971566.zip
dev-python/datashape: Bump
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/datashape/Manifest1
-rw-r--r--dev-python/datashape/datashape-0.5.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/datashape/Manifest b/dev-python/datashape/Manifest
index 9b04a8fd7c4c..dd19e7b5a111 100644
--- a/dev-python/datashape/Manifest
+++ b/dev-python/datashape/Manifest
@@ -6,3 +6,4 @@ DIST datashape-0.4.7.tar.gz 92581 SHA256 1028378bb56e8546a07cd3ad09247672516468a
DIST datashape-0.5.0.tar.gz 97748 SHA256 d0b7eafd84fbc75941e274b1bd9c26327ee90f3a1872e7e9b72693f49bee4f0f SHA512 670049fdc6e829805bdf4bf50ffb037bfa2b48fcc3e8772ac82a030fbb3d9c2dd084b6d2ed79cbe08a6e8d074b9fc54a7836f530f5fb45bf96df8b2fb9a8eaa1 WHIRLPOOL bc30f093889951ce47e9eacbad7dbfc5dd1257c9a6cc2a7692660b28b123fc40912f68dfb52bc387fc03043dd35cff5b7d51693ee69f153539653536738c6590
DIST datashape-0.5.1.tar.gz 98160 SHA256 bbb1dbcbfa285c4ecf0d2ee14b7017b3ea357935537c736bc51eca07d2bd4f47 SHA512 cb882b76f2b0a0f0321fcb41fe59dd5a1465f07bc58dc817400cd2d17d8a2b34a2ca944c24629616684ea6c6cf3f19365f539a2b58baf83f8ecebe6896a8beb8 WHIRLPOOL 7b78d1a0fbc1233666915715448d4552b948b82198773b5d13f43169f59513e43ceca2ccb9d625d64d83f58f122272f56b952cb3d0156c0f8b7512427f702490
DIST datashape-0.5.2.tar.gz 99032 SHA256 7f964969944bfcd61904c4f40210429723d0db91e57d543660b38bbe1da4806b SHA512 731d65d0dd82310d0101386bb0df8169f940d8e6e3a749fd2b40996ee8dddf046ae83bdee0417e0bb156e6d8c00a03f53839a1b5eae4c4867eedfff338df99e6 WHIRLPOOL f876bfe31446b0a573b8293a068ef45fc53dc1845aa10bf86ab23ffff9ea2fc6a481f5c11288c5b971fc626b93dfd41baf22f54423b13d441d167d60ab598182
+DIST datashape-0.5.3.tar.gz 99757 SHA256 a4c9d54145ce9ec5d971073aec72c3066efec5a180d711f5a07d02b434e822d3 SHA512 f9542bdfbbf1d28023551023fef283385ee4b431e28c7ca8552727f5eb9deee9b6d022acbc694070f13e1441c1b0fe30963719e7b11326969edeca1193db41ab WHIRLPOOL 03c08314a3f0933f1b5a90061d43ca7c487be7e05a34349e6a464c8f3524cafbb62b2605fd18b3ca861c0fc733b04d9a788dbd9c54730c06c8118a72daa63e11
diff --git a/dev-python/datashape/datashape-0.5.3.ebuild b/dev-python/datashape/datashape-0.5.3.ebuild
new file mode 100644
index 000000000000..602a6f46c051
--- /dev/null
+++ b/dev-python/datashape/datashape-0.5.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Language defining a data description protocol"
+HOMEPAGE="https://github.com/ContinuumIO/datashape"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ >=dev-python/multipledispatch-0.4.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/'sphinx.ext.intersphinx', //" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}