summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-07-05 00:00:35 -0300
committerMatt Turner <mattst88@gentoo.org>2023-07-13 12:18:50 -0400
commit40e4563b11f5483e5722ef3c210ec5298ae96e20 (patch)
treea25a0fc0de5d59580369205e050ecdbc8cf2db66
parentsys-apps/systemd-utils: skip musl patch applied upstream (diff)
downloadgentoo-40e4563b.tar.gz
gentoo-40e4563b.tar.bz2
gentoo-40e4563b.zip
gnome-extra/gnome-weather: Version bump to 45_alpha
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31751 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/gnome-weather/Manifest1
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-45_alpha.ebuild53
-rw-r--r--profiles/package.mask1
3 files changed, 55 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index 1046872ef8b4..e2ed105a3689 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1 +1,2 @@
DIST gnome-weather-44.0.tar.xz 236152 BLAKE2B 40ff3e2d3339fbab0da3629c95e843ad3a304c76aadc6f7772ae7fd38337dc7c3aad1e90cfee1a513b770788a223838b741728d6307b815fa50453f9d355c903 SHA512 56f4eb716793c047b438c6f5839bc60bae478b6f407bf067c4df51be35a96b31d9d98b33faf7f6e52606b22827f0da72289558da89c2746ee6e2fad6d3332e05
+DIST gnome-weather-45.alpha.tar.xz 236168 BLAKE2B a36c36171c7b28db9cb4f41299d334278a8526486a183f423d811ec154a85bc64964714cf1ed2552f6823240dd0b133d2b4a7cc38df006cf97e057f2eb081da5 SHA512 9d1f9397dbab5b2914088808a1e6730557732648b6d60245e9afddfa44c029bc19b35d852dd122aee5ff550f19311915bfee7afe100374d492b007c9d78c7d8c
diff --git a/gnome-extra/gnome-weather/gnome-weather-45_alpha.ebuild b/gnome-extra/gnome-weather/gnome-weather-45_alpha.ebuild
new file mode 100644
index 000000000000..96d3c2948e58
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-45_alpha.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=gui-libs/gtk-4.5:4
+ >=dev-libs/gjs-1.71.0
+ >=app-misc/geoclue-2.3.1:2.0
+ >=gui-libs/libadwaita-1.4_alpha:1=
+ >=dev-libs/libgweather-3.90.0:4=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 55b9b663111c..b7b430b7aea0 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -90,6 +90,7 @@ dev-perl/Gtk2-Notify
>=gnome-base/gsettings-desktop-schemas-45_alpha
>=gnome-extra/gnome-shell-extensions-45_alpha
>=gnome-extra/gnome-system-monitor-45_alpha
+>=gnome-extra/gnome-weather-45_alpha
>=gui-libs/gtk-4.11
>=gui-libs/libadwaita-1.4_alpha
>=media-gfx/gnome-font-viewer-45_alpha