summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-15 23:36:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-15 23:36:10 +0200
commit40f3372df3972f71da0a28f276ac318ae671bdc3 (patch)
tree902f41f99daf6deff8f57ec691299632dae782e0
parentdev-python/pyopenssl: Remove old (diff)
downloadgentoo-40f3372d.tar.gz
gentoo-40f3372d.tar.bz2
gentoo-40f3372d.zip
dev-python/werkzeug: Force /tmp as tmpdir to fix AF_UNIX name limit
Force using /tmp for tests rather than ${T}, as the latter can easily cause AF_UNIX socket paths to exceed the limit. Closes: https://bugs.gentoo.org/790416 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/werkzeug/werkzeug-2.0.0.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/werkzeug/werkzeug-2.0.0.ebuild b/dev-python/werkzeug/werkzeug-2.0.0.ebuild
index b846c49b5395..d9a91a7036a5 100644
--- a/dev-python/werkzeug/werkzeug-2.0.0.ebuild
+++ b/dev-python/werkzeug/werkzeug-2.0.0.ebuild
@@ -36,5 +36,7 @@ DEPEND="
distutils_enable_tests pytest
python_test() {
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
epytest -p no:httpbin tests
}