summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-11-29 19:59:01 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-02 22:48:16 +0800
commit40fd818d2894a3f48c00e1cc857c733584b355c6 (patch)
tree9d5d247d5c7d703234024c4ed45bd48f18110436
parentprofiles/features/selinux: mask portage[py2_7] revdeps for libselinux-3 (diff)
downloadgentoo-40fd818d2894a3f48c00e1cc857c733584b355c6.tar.gz
gentoo-40fd818d2894a3f48c00e1cc857c733584b355c6.tar.bz2
gentoo-40fd818d2894a3f48c00e1cc857c733584b355c6.zip
dev-python/ipy: bump 1.00
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
-rw-r--r--dev-python/ipy/Manifest1
-rw-r--r--dev-python/ipy/ipy-1.00.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/ipy/Manifest b/dev-python/ipy/Manifest
index f4e6af542951..547715a7c126 100644
--- a/dev-python/ipy/Manifest
+++ b/dev-python/ipy/Manifest
@@ -1 +1,2 @@
DIST IPy-0.83.tar.gz 31816 BLAKE2B 89ca11d292ff3ed6f633aacc2c689e710c5ed43ada32e75425f653bfe87bcf6eb777d5ede33133362833099e51b2248f5e846bae82b28a6050500f25679ddbfb SHA512 6bd69d96fa77dc4ceaf119b81c19a524b871badb37665a763a055e1c8b2ce3433c6e9534f03aa64d02e559dca2fac2c4e1d09b7fd78ed79c0fded88f803ad2de
+DIST IPy-1.00.tar.gz 35324 BLAKE2B a0e04201a59c61e5cc8f7ce2837c83dded99d0d786406e2e341183a0903d43ed5496ae8ea05d1bee019007bfef7420be623ab3dc08cce33812f1720a59ca413d SHA512 94a8f26cad0d966fdf8d4e57284eadf4cfde88515af6f5aafc8f9597eb0758324b876039d1a121021ba1ac26be2e2ffa89a3f5803dddefdee03fdb5d65b07a81
diff --git a/dev-python/ipy/ipy-1.00.ebuild b/dev-python/ipy/ipy-1.00.ebuild
new file mode 100644
index 000000000000..f2312104ecf0
--- /dev/null
+++ b/dev-python/ipy/ipy-1.00.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 python{3_5,3_6,3_7,3_8} pypy )
+
+inherit distutils-r1
+
+MY_PN="IPy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="https://github.com/haypo/python-ipy/wiki https://pypi.org/project/IPy/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ # 1 test fail under pypy, persistent from 0.82a, not a regression.
+ cp -r test_doc.py README.rst test "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "${PYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${PYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}