summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-07 18:37:43 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-07 18:49:17 +0200
commit4115b99f835435c85c91ac8ae9b41d9eb22f035b (patch)
treef2068dc9691b14b0d0a5eb9062d6d806263a6302
parentdev-python/decorator: add 5.1.1 (diff)
downloadgentoo-4115b99f.tar.gz
gentoo-4115b99f.tar.bz2
gentoo-4115b99f.zip
dev-python/prettytable: add 3.0.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/prettytable/Manifest1
-rw-r--r--dev-python/prettytable/prettytable-3.0.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index be14e47c6596..c7b9e3e934e9 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -3,3 +3,4 @@ DIST prettytable-2.2.1.tar.gz 45102 BLAKE2B 59fe355603791c8b3a584b1d1f2864559a7e
DIST prettytable-2.3.0.tar.gz 49386 BLAKE2B 368dd454da9dde3900009ed52c0d55c30ed69315b36fb53eaebc764af419851b858dc648ac5d8ca62592c2aaa68dac91ac03a1a1bf29d10ee5162981f2937c22 SHA512 feeaeeb0a1897c0aaa2bc0ac7f470244529e8c70debb26976494719607840c8b8a80698b7e463402031b250fe152091e947555be2a6f983764e01bdaa1a71a22
DIST prettytable-2.4.0.tar.gz 49756 BLAKE2B 594dea7e1c3c9ba070420c83960b9fc4016d25bd883126ed2331cb5ce06909fad92e94ec141e1b4838233f00cfabc394e1a7025aa02cf246e8608903bb45533c SHA512 50983855868d23a590004dcb81ad9a3f22191c656532683f71260a369df5bd2a0001db946268944cc169528f64f36833eb524fc46efabe562434ec32832ce011
DIST prettytable-2.5.0.tar.gz 50015 BLAKE2B 75bf06625ee8aaa495ce86f69d751bf89edb8fd0c530009cd4eec9f44b6155d0168d2f4b9f55bef6c3c591a3be17bd87eefc447315f9ed867f6a7edd8c0225c5 SHA512 e4f07e842668b3874ecb329b5e9d6b61433c6ef78f3df6b9872bd7edd1d7266bf61e80b8aab641d42eb7dce1f2fc3463e1598128763ca4998618ea835cd74fef
+DIST prettytable-3.0.0.tar.gz 50012 BLAKE2B 9a1c57abf46fd00fa74022ad9a8bd19c5f501610ac4dcd806511f5cd9e0ab17cbf24ce90b8f1c3f98db5601e1df75cf57c7709c84e0c3b703ebe2d69f57294d3 SHA512 f7b03ee1c1371187708b1cd7724f1afead1249a796928d2abdce42fa834ee128e930f20aef1df579426c65f1fb574b1a831e521ade6e9e65977d5dd88bafc5af
diff --git a/dev-python/prettytable/prettytable-3.0.0.ebuild b/dev-python/prettytable/prettytable-3.0.0.ebuild
new file mode 100644
index 000000000000..51b2783bead9
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest