summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-20 13:35:25 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-20 14:03:23 +0200
commit4118489f003bed40dc9c799d3ba81b8417c812d6 (patch)
tree56ab76b6506c32503ca46860c62b9aac8508a9e1
parentmedia-gfx/blender: Remove option to build standalone cycles binary (diff)
downloadgentoo-4118489f.tar.gz
gentoo-4118489f.tar.bz2
gentoo-4118489f.zip
dev-python/libnacl: Bump to 1.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/libnacl/Manifest1
-rw-r--r--dev-python/libnacl/libnacl-1.8.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/libnacl/Manifest b/dev-python/libnacl/Manifest
index dc991fce9560..b62fd3b8ac51 100644
--- a/dev-python/libnacl/Manifest
+++ b/dev-python/libnacl/Manifest
@@ -1 +1,2 @@
DIST libnacl-1.7.2.tar.gz 43343 BLAKE2B 4f7d03661e1385033c51821bf673c81ced11a1523b371ec7da42ed9cf75bdaadee1e679059dfae85871530652b5fea80bfb91c19a8a1eefb4ecf1b8661f11e19 SHA512 a4efbf73f73d9493ac365efa5a5bd6481f85ce4c880ad236bbf7478090bdea857e78e33e445c4e467d2a2032040863b835f32f9a942d2f1e467015bd76b0d469
+DIST libnacl-1.8.0.gh.tar.gz 43351 BLAKE2B 4ba0ebcb50755d80418ffe7238c65d9309954cb2a0eac61937c488144b56093f3fcd87f0bf22a290c7b415c70cb781fbf7a2c608863d43694230fe34b3ad418e SHA512 7a39d646083591782691c4d58fd4d743b385ee553bcc4c4741707a237fa3b1213629b5070390526175bdfe8436859aa7711779ff8b22a981227edb30b94e82d6
diff --git a/dev-python/libnacl/libnacl-1.8.0.ebuild b/dev-python/libnacl/libnacl-1.8.0.ebuild
new file mode 100644
index 000000000000..fbdab660d5d5
--- /dev/null
+++ b/dev-python/libnacl/libnacl-1.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="
+ https://libnacl.readthedocs.io/
+ https://github.com/saltstack/libnacl/
+ https://pypi.org/project/libnacl/
+"
+# forked because upstream didn't push the tag for almost a year now
+SRC_URI="
+ https://github.com/mgorny/libnacl/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/libsodium
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -p 'test_*.py' tests/ ||
+ die "Tests failed with ${EPYTHON}"
+}