summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-07 21:57:14 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-07 22:21:34 +0300
commit4130afdbbb2b1a2be656ec9a2c0f90619c2f7cc4 (patch)
tree0014b463f5231a9ba2fdac0757cfc706119ed43d
parentdev-python/PyPDF2: add 2.10.0 (diff)
downloadgentoo-4130afdbbb2b1a2be656ec9a2c0f90619c2f7cc4.tar.gz
gentoo-4130afdbbb2b1a2be656ec9a2c0f90619c2f7cc4.tar.bz2
gentoo-4130afdbbb2b1a2be656ec9a2c0f90619c2f7cc4.zip
dev-python/keyring: add 23.8.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/keyring/Manifest1
-rw-r--r--dev-python/keyring/keyring-23.8.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index 191067e86315..bc4e22a8fd3a 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1,2 +1,3 @@
DIST keyring-23.6.0.gh.tar.gz 45236 BLAKE2B 98ea183760da39512fcebd93b182b10f031853ee88d4e93add119a760851d9552d830fe599c57937d84a23df67b6a6ca9e33a5623a034da2fc8b28c0216a6aaf SHA512 dc196914389ad12f89652614ea00b2ca17cf22471f1bd41ed3cb58519b1ca9b8ad7f497707d77c31d1354c12d73b9881d4f5511c61a6dc562ec358f3009a0c70
DIST keyring-23.7.0.gh.tar.gz 45352 BLAKE2B 8cad2f2c7443adf710220d546a080c4ca106c9939f5a91ef56cd6f034cf71fcb86515005f17adf3ffc35ab616ed722e469ae0c92040d57d4183d6a4ced6a2682 SHA512 351afb3e376350192d5b02f2cb9bdf4bc28d551e4184145bd05ba7fd0c950c7cfeae0f75ed63bfed670648e2b7d2f491b894939d37edbdb0869d4cb74a4fc97e
+DIST keyring-23.8.0.gh.tar.gz 45941 BLAKE2B db78b53e2d2964c65d850df4226954db696037fa220f003d91e94603ce12b4d3668b7b53a91b71244d8555ba9c9195309a2e8a9aafd88d12da0f1a916b469857 SHA512 daa0b88b9f7c6e94eb589c15f364ff2a0fb83cead50b4fcafa6214072681d4346c8abe7ee8ab76f0ab93b7c7bccc551f65912dbfa749256e226f1e84793676dc
diff --git a/dev-python/keyring/keyring-23.8.0.ebuild b/dev-python/keyring/keyring-23.8.0.ebuild
new file mode 100644
index 000000000000..a90ebe22521a
--- /dev/null
+++ b/dev-python/keyring/keyring-23.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="
+ https://github.com/jaraco/keyring/
+ https://pypi.org/project/keyring/
+"
+SRC_URI="
+ https://github.com/jaraco/keyring/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/secretstorage-3.2[${PYTHON_USEDEP}]
+ >=dev-python/jeepney-0.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # this test fails if importlib-metadata returns more than one
+ # entry, i.e. when keyring is installed already
+ tests/test_packaging.py::test_entry_point
+)
+
+EPYTEST_IGNORE=(
+ # apparently does not unlock the keyring properly
+ tests/backends/test_libsecret.py
+ # hangs
+ tests/backends/test_kwallet.py
+)