summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-10-01 22:49:01 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-10-01 22:49:08 +0100
commit41397061c6b11b25c2d2b812f290196c99506a51 (patch)
treeacaf6513664eea2326ccc53a77ca946618621a5e
parentdev-util/rr: bind to library subslots (diff)
downloadgentoo-41397061.tar.gz
gentoo-41397061.tar.bz2
gentoo-41397061.zip
dev-util/rr: switch from cmake-utils to cmake
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-util/rr/rr-5.3.0-r2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/rr/rr-5.3.0-r2.ebuild b/dev-util/rr/rr-5.3.0-r2.ebuild
index a6c39d9625b4..e46b29249fe7 100644
--- a/dev-util/rr/rr-5.3.0-r2.ebuild
+++ b/dev-util/rr/rr-5.3.0-r2.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
CMAKE_BUILD_TYPE=Release
-inherit cmake-utils linux-info python-single-r1
+inherit cmake linux-info python-single-r1
DESCRIPTION="Record and Replay Framework"
HOMEPAGE="https://rr-project.org/"
@@ -44,7 +44,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -i 's:-Werror::' CMakeLists.txt || die #609192
}
@@ -55,7 +55,7 @@ src_test() {
return 0
fi
- cmake-utils_src_test
+ cmake_src_test
}
src_configure() {
@@ -64,5 +64,5 @@ src_configure() {
-Ddisable32bit=$(usex !multilib) #636786
)
- cmake-utils_src_configure
+ cmake_src_configure
}