summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-10-19 09:29:15 -0400
committerCraig Andrews <candrews@gentoo.org>2020-10-19 09:32:09 -0400
commit414d951859e2b6e245e2e0472dda542d7ce5380b (patch)
tree20333d718a3006376fc77a5e65fdb3ce50a80957
parentmedia-plugins/kodi-game-libretro-twentyfortyeight: 1.0.0.115 version bump (diff)
downloadgentoo-414d9518.tar.gz
gentoo-414d9518.tar.bz2
gentoo-414d9518.zip
media-plugins/kodi-pvr-hts: 7.2.1 version bump
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--media-plugins/kodi-pvr-hts/Manifest1
-rw-r--r--media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.2.1.ebuild33
-rw-r--r--media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild1
3 files changed, 34 insertions, 1 deletions
diff --git a/media-plugins/kodi-pvr-hts/Manifest b/media-plugins/kodi-pvr-hts/Manifest
index ab5b2938207e..eab66c9da8af 100644
--- a/media-plugins/kodi-pvr-hts/Manifest
+++ b/media-plugins/kodi-pvr-hts/Manifest
@@ -8,3 +8,4 @@ DIST kodi-pvr-hts-4.4.20.tar.gz 161693 BLAKE2B d69e72c8d189b540f2d8abc97c50e5a9e
DIST kodi-pvr-hts-7.1.1.tar.gz 167379 BLAKE2B f2391d7997a7e17ed1fb7b2326cdb0cddfecdf9a6b0785fc89ecf8b58004575c6b7a1f6efb976edda827b9e83d334e0bba518498886c1e1769b9ed1deacf25d7 SHA512 5d1e049c23e82964ab87b22c716028d57322f81b749f84f07f66e3bbd2990e711186eee2b562d1f326a369b5fc52d1f7b2aea31b4d8edc827f6555965fec2b69
DIST kodi-pvr-hts-7.1.4.tar.gz 167634 BLAKE2B 34c19b9be6f8e66c22b93e74703d55ccf66970fb39b4c2ac52146aa9d94175280406339fbe6651a53be4b9216713dbeb25fc004f9959a1ce1db42e13b0aec2f7 SHA512 91f9420ad88ec806d2d16e618827583039b90e488014d0f998108c9d94906aa247755f5d53dc4b59badc9fdfad96c975b0d7c98ef0ffd7116171e8abd247c94b
DIST kodi-pvr-hts-7.2.0.tar.gz 167998 BLAKE2B 4da53589b58849259d66a03d2f719067cc1749ea181ad6037f03ca178879a34e209422039a1b2d0b3900ee2a2ef65d32a09cae0f177dc17dd8aa97e06dea4f2b SHA512 736188c4464c9110e4916223cd0aa79195547d4ff568aea711aa42c1145d5aa981d1d5f62d4ed79b37575592bda9f2bbc532eff7b09e48785e644e8fdea668c0
+DIST kodi-pvr-hts-7.2.1.tar.gz 180461 BLAKE2B c0beed28549d80f71e5bb7197a396c5abf6c26e119caee5624e37c250d718425519d93317e26e1fa831f13d83903807e2fa3917831645ed83e465f8177cc77d3 SHA512 6f971a14e04c4ebb7b300286f7b10f64092eac91a63cbb1ea7ce0d47431231743080b73eb9939273e775f69c1659c2daa669ee53b22be3dafa4c732b095c43f8
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.2.1.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.2.1.ebuild
new file mode 100644
index 000000000000..c5e930e99316
--- /dev/null
+++ b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-7.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake kodi-addon
+
+DESCRIPTION="Tvheadend Live TV and Radio PVR client addon for Kodi"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.hts"
+SRC_URI=""
+
+if [[ ${PV} == 9999 ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.hts.git"
+ inherit git-r3
+else
+ CODENAME="Matrix"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.hts/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.hts-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-19*
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild
index 6c70bf3c61b3..65e04aa1556d 100644
--- a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild
+++ b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild
@@ -25,7 +25,6 @@ SLOT="0"
IUSE=""
DEPEND="
- =dev-libs/libplatform-2*
~media-tv/kodi-9999
"