summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-02 07:22:48 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-02 08:37:12 +0100
commit415c25da352f39b8477ce9a75ddeba5ea775dd78 (patch)
treecb4e26e033cb99588dd6b66e0dd2e298376de733
parentdev-python/cx_Freeze: Bump to 6.13.1 (diff)
downloadgentoo-415c25da.tar.gz
gentoo-415c25da.tar.bz2
gentoo-415c25da.zip
dev-python/lark: Bump to 1.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lark/Manifest1
-rw-r--r--dev-python/lark/lark-1.1.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/lark/Manifest b/dev-python/lark/Manifest
index 79fe7deabe7e..660b57ec424f 100644
--- a/dev-python/lark/Manifest
+++ b/dev-python/lark/Manifest
@@ -1,2 +1,3 @@
DIST lark-1.1.2.tar.gz 243201 BLAKE2B 0f1b51b0276ad893f29d0afa6c3e18211b0b92832c8c6f5cba6bbe9e03486b5598f55fa7c6f4d77798ed070decd902d01faa4df62039031fe21d392d29122125 SHA512 fc797c263410f461e1ef28fbbba526472b9c4d8dbb296b309e59daa5945fdcc0c2f9347b3b4bf78e189c6a3d8f1333c74a5f3d80b82ee54867181b84ba263c00
DIST lark-1.1.3.tar.gz 245913 BLAKE2B 4c7b53d123aa7cdffcb16027921fced2f94dc0e5b9b816825f297629a9ff446758d9a700dc0f243f3d4c478fc992bbf5bfb38c51c2be3c8379df06b41044c624 SHA512 5359a29852554049ecee77a4151a2c64c5af72eccf5c2bb07926b0c131caac15cc51777c2df1d2c736e9e2b45d59543aa8a6d16ef2cb92ea7f8564c7ac06edb2
+DIST lark-1.1.4.tar.gz 246520 BLAKE2B 08073f89a3403d5e722b3af4d9226ea4ca890a7ad9978fb69f023f1219bb2d148533a68810188d3af35770cc36d29629a1c57a3fbab4098e9ec3d4e73f68ffe8 SHA512 32498f8c387320dce89ebab66e9eed49dc83b855060a8fb9459e6323d0d783ff7184ac997ff095fead09766c00f28c12ccbcd614effb8344ba49df51f7b5a566
diff --git a/dev-python/lark/lark-1.1.4.ebuild b/dev-python/lark/lark-1.1.4.ebuild
new file mode 100644
index 000000000000..48eebe3a0446
--- /dev/null
+++ b/dev-python/lark/lark-1.1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to propose a modern general-purpose parsing library for Python"
+HOMEPAGE="
+ https://github.com/lark-parser/lark/
+ https://pypi.org/project/lark/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/lark/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # require dev-python/js2py which is a really bad quality package
+ tests/test_nearley/test_nearley.py
+ )
+
+ if has "${EPYTHON}" pypy3 python3.{8,9}; then
+ EPYTEST_IGNORE+=(
+ # test using Python 3.10+ syntax
+ tests/test_pattern_matching.py
+ )
+ fi
+
+ epytest
+}