summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2021-09-24 17:25:50 -0400
committerMike Frysinger <vapier@gentoo.org>2021-09-24 17:28:25 -0400
commit4161aec572d27765b414be7efb1157aec03ad4ab (patch)
treef1ea440ff1c3939f9c79f05aab4f3e9180fd3832
parentgames-emulation/pcsx2: use shared=off to fix live build (diff)
downloadgentoo-4161aec5.tar.gz
gentoo-4161aec5.tar.bz2
gentoo-4161aec5.zip
app-portage/elt-patches: add fsanitize & fuse-ld support
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
-rw-r--r--app-portage/elt-patches/Manifest1
-rw-r--r--app-portage/elt-patches/elt-patches-20210924.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/elt-patches/Manifest b/app-portage/elt-patches/Manifest
index 1070f6bb4e06..9d2b73be4806 100644
--- a/app-portage/elt-patches/Manifest
+++ b/app-portage/elt-patches/Manifest
@@ -1,2 +1,3 @@
DIST elt-patches-20201205.tar.xz 39240 BLAKE2B aa2e2377f0d0cba14f38c59664174d066eff04c9d2a71346c998c4324987fbce25cfd91b79e8e40bde0d81bf7d3c43126bffd0a6b0b219aaad11f4f9f22abde4 SHA512 67e199f060e2c93e01b7a7809f52c0a18d82e86f1b1eb34b965c2acd24e5538a874b820028e363d3002cf58b43c2fe3376ae28d2bef0ca81feabb90c83ae47c2
DIST elt-patches-20210827.tar.xz 39264 BLAKE2B 271565e4ab906374ca30f69f5ebc8c14cbda5c176b7d54de4315adf83c12111cab4d04254f5bbbc13cf6bc701ba8a940def98e3a983d199ca6aedfe82a280682 SHA512 bf7d50df82e6335879ba4e130817bce67c4e63c55e2ac7249fa35b60f6b73290f857562433477907283b41b137bf12ee254b5bea20f8eebf173c6584d74f5e49
+DIST elt-patches-20210924.tar.xz 40140 BLAKE2B 81970936e9a362cb9ee51a381e4fd2f888c62df2fdcf7af419c3574d37857988c92daa3b1b90530f453aa532161dd0bdd3697d4c3b0a0a47a05a7546e7fd5052 SHA512 3a55d053e488590a78bbfe0a4eb3153ea51ca70784708e0131016771a1c1dab591a42442b2d97d1a335c9a209fc03410df3cd56741d6f7cffb92d0737c5944c2
diff --git a/app-portage/elt-patches/elt-patches-20210924.ebuild b/app-portage/elt-patches/elt-patches-20210924.ebuild
new file mode 100644
index 000000000000..b228aabe08d0
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20210924.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+
+RDEPEND="sys-apps/gentoo-functions"
+BDEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX}" install
+}