summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 20:37:53 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 21:15:23 +0200
commit4163e796f3c2dc0116d2caf063f3692b55dc81da (patch)
tree049aabc1846e2d564820675a01ead819ef991363
parentdev-python/pathtools: Clean old versions up (diff)
downloadgentoo-4163e796f3c2dc0116d2caf063f3692b55dc81da.tar.gz
gentoo-4163e796f3c2dc0116d2caf063f3692b55dc81da.tar.bz2
gentoo-4163e796f3c2dc0116d2caf063f3692b55dc81da.zip
dev-python/kombu: Clean old versions up
-rw-r--r--dev-python/kombu/Manifest1
-rw-r--r--dev-python/kombu/files/kombu-3.0.26-pymongo-test-fix.patch40
-rw-r--r--dev-python/kombu/kombu-3.0.34.ebuild110
3 files changed, 0 insertions, 151 deletions
diff --git a/dev-python/kombu/Manifest b/dev-python/kombu/Manifest
index 221e9f562fc6..dac5d552aa5d 100644
--- a/dev-python/kombu/Manifest
+++ b/dev-python/kombu/Manifest
@@ -1,3 +1,2 @@
-DIST kombu-3.0.34.tar.gz 380374 SHA256 8878ff19b09d86b2689682a4a3eb163d70115ef4ebd974966079a0edd80075da SHA512 9de5d9e4784d814f8c40633bfac08a4e9279d55d2122d1cfdee6418066ba61e0ef7dcaba9cf21d2b0b99989ba292125bbe4b38be90ecc288cb038aea638d1508 WHIRLPOOL d0dfe755af559f4c1d0e8fb6bbe3c7767874a34db57f4958196b853147061e078fac9d5ab31957ab88707220e738a05248afa5d86d9fbdd1a5619aab80d9711a
DIST kombu-3.0.37.tar.gz 411790 SHA256 e064a00c66b4d1058cd2b0523fb8d98c82c18450244177b6c0f7913016642650 SHA512 ba9bb00e23ce2d3da87eb07aacff8d63ef9879e6ca9f3fe82653cc2ee91610199fe8fc778d7c2e00df05b46130ecda0bdeceda48192b8af1fb0eca41fbb44712 WHIRLPOOL 1e3344eb25024e94d341a3928bd04a9fd13bb41fefd7254e5f2dd70a8b235ae48b93d9b003b21d9ccde4ebdb8d1f349d9af6d54b51c74d6c6b1ee7913ee06919
DIST kombu-4.0.2.tar.gz 418051 SHA256 d0fc6f2a36610a308f838db4b832dad79a681b516ac1d1a1f9d42edb58cc11a2 SHA512 99be6aa833eedc02897da90ebbd838bf0ac2a21db91350e235fae99ce31607cbc749f73f99d24f76acfc68b81d6263688d35b72ed62bb21d024a3ab385fa666e WHIRLPOOL e140f700c2e00ab892b54664d61c56343fb4d51f65fc0c42e2b4e0b0f75836889f5746061db1f31d3ba5f5981946d47d29ba64b8e6f0561fec054b77167d090e
diff --git a/dev-python/kombu/files/kombu-3.0.26-pymongo-test-fix.patch b/dev-python/kombu/files/kombu-3.0.26-pymongo-test-fix.patch
deleted file mode 100644
index b2e1185b7ca8..000000000000
--- a/dev-python/kombu/files/kombu-3.0.26-pymongo-test-fix.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-https://github.com/celery/kombu/commit/8e6aed9fcf978b6c34108c0d37b720bd125f0352
-diff --git a/kombu/tests/transport/test_mongodb.py b/kombu/tests/transport/test_mongodb.py
-index b4d10fc..58c92e7 100644
---- a/kombu/tests/transport/test_mongodb.py
-+++ b/kombu/tests/transport/test_mongodb.py
-@@ -64,12 +64,12 @@ def test_custom_credentials(self):
-
- @skip_if_not_module('pymongo')
- def test_options(self):
-- url = 'mongodb://localhost,localhost2:29017/dbname?safe=true'
-+ url = 'mongodb://localhost,localhost2:29017/dbname?tz_aware=true'
- c = self._get_connection(url)
-
- hostname, dbname, options = c.channels[0]._parse_uri()
-
-- self.assertEqual(options['safe'], True)
-+ self.assertEqual(options['tz_aware'], True)
-
- @skip_if_not_module('pymongo')
- def test_real_connections(self):
-diff --git a/kombu/transport/mongodb.py b/kombu/transport/mongodb.py
-index 9137132..40b00ff 100644
---- a/kombu/transport/mongodb.py
-+++ b/kombu/transport/mongodb.py
-@@ -176,9 +176,14 @@ def _parse_uri(self, scheme='mongodb://'):
-
- return hostname, dbname, options
-
-+ def _prepare_client_options(self, options):
-+ if pymongo.version_tuple >= (3, ):
-+ options.pop('auto_start_request', None)
-+
- def _open(self, scheme='mongodb://'):
- hostname, dbname, options = self._parse_uri(scheme=scheme)
-
-+ self._prepare_client_options(options)
- mongoconn = MongoClient(
- host=hostname, ssl=options['ssl'],
- auto_start_request=options['auto_start_request'],
-
diff --git a/dev-python/kombu/kombu-3.0.34.ebuild b/dev-python/kombu/kombu-3.0.34.ebuild
deleted file mode 100644
index 10b5eef3d878..000000000000
--- a/dev-python/kombu/kombu-3.0.34.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="AMQP Messaging Framework for Python"
-HOMEPAGE="https://pypi.python.org/pypi/kombu https://github.com/celery/kombu"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="amqplib doc examples msgpack sqs test"
-
-# couchdb backend support possible via dev-python/couchdb-python
-# ditto dev-python/kazoo(>=1.3.1) and dev-python/beanstalkc
-PY27_GEN_USEDEP=$(python_gen_usedep python2_7)
-PYPY_GEN_USEDEP=$(python_gen_usedep python2_7 pypy)
-RDEPEND="
- >=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
- >=dev-python/py-amqp-1.4.9[${PYTHON_USEDEP}]
- <dev-python/py-amqp-2.0[${PYTHON_USEDEP}]
- dev-python/pyro:4[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/pyzmq-13.1.0[${PYTHON_USEDEP}]' 'python*')
- amqplib? ( >=dev-python/amqplib-1.0.2[${PYTHON_USEDEP}] )
- sqs? ( >=dev-python/boto-2.13.3[${PY27_GEN_USEDEP}] )
- msgpack? ( >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}] )"
-# Fix to https://github.com/celery/kombu/issues/474 obliges dev-python/pymongo to >=-3.0.2
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-0.7[${PYTHON_USEDEP}]
- test? (
- >=dev-python/unittest2-0.5.0[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nose-cover3[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.0[${PYTHON_USEDEP}]
- >=dev-python/mock-0.7.0[${PYPY_GEN_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- >=dev-python/redis-py-2.10.3[${PYTHON_USEDEP}]
- >=dev-python/pymongo-3.0.2[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}] )
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/beanstalkc[${PY27_GEN_USEDEP}]
- dev-python/couchdb-python[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-issuetracker-0.9[${PYTHON_USEDEP}] )"
-
-# kazoo and sqlalchemy are optional packages for tests.
-# Refrain for now, no established demand for it from users
-
-# Req'd for test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-PY27_REQUSE="$(python_gen_useflags 'python2*')"
-REQUIRED_USE="
- sqs? ( ${PY27_REQUSE} )
- doc? ( ${PY27_REQUSE} amqplib sqs )" # 2 deps in doc build are py2 capable only
-
-PATCHES=(
- "${FILESDIR}"/${PN}-NA-tests-fix.patch
- )
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
-}
-
-python_prepare_all() {
- # https://github.com/celery/kombu/issues/246
- sed -e 's:kombu.transports:kombu.transport:' -i funtests/tests/test_django.py
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # Doc build must be done by py2.7
- # Doc build misses and skips only content re librabbitmq which is not in portage
- if use doc; then
- emake -C docs html || die "kombu docs failed installation"
- fi
-}
-
-python_test() {
- export DJANGO_SETTINGS_MODULE="django.conf"
- # https://github.com/celery/kombu/issues/474
- # tests need </pymongo-3.0; known to cause some breakage
- if python_is_python3; then
- 2to3 --no-diffs -w build/lib/kombu/transport/
- nosetests --py3where=build/lib kombu/tests || die "Tests failed under ${EPYTHON}"
- else
- nosetests "${S}"/kombu/tests || die "Tests failed under ${EPYTHON}"
- # funtests appears to be coded only for py2, a kind of 2nd tier. pypy fails 6.
- # https://github.com/celery/kombu/issues/411
- # Fix to https://github.com/celery/kombu/issues/474 breaks the
- # funtests under >=dev-python/pymongo-3.0.2
-# if [[ "${EPYTHON}" == python2.7 ]]; then
-# pushd funtests > /dev/null
-# esetup.py test
-# popd > /dev/null
-# fi
- fi
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- use doc && local HTML_DOCS=( docs/.build/html/. )
- distutils-r1_python_install_all
-}