summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-06 16:45:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-06 16:46:48 +0200
commit41662c9f2170bc1c66fea59be6acba3ee0807504 (patch)
tree29f5d18f322d20cfd38cf34bbdf08effff91ef29
parentdev-python/mongoengine: Remove old (diff)
downloadgentoo-41662c9f.tar.gz
gentoo-41662c9f.tar.bz2
gentoo-41662c9f.zip
dev-python/pylint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.7.4.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 1f76320c75ed..95131704246a 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1 @@
-DIST pylint-2.7.4.tar.gz 715507 BLAKE2B 141506c067195422d0b052924baf87c363c89e28b3279f5173d989ac9247163184840251bd05dfb7dbb765f7b2e921a851fde0323b6c4cc231bc58911c77f692 SHA512 2b7ec9ab3325209021cb0282a6dacabf7ddd1f5e4049157610015ac8c11413471defc9e0528f81e1a60c2b259260f1bde1d04286776b3f32f771968b9866d734
DIST pylint-2.8.2.gh.tar.gz 734667 BLAKE2B 1525273298f39163de4db7946a749768cb9bcf7e11f89791944ccb5fb8d0918eedfc80d5e559d33934d468dd5781d4cb4921b9407daf2842613a8e3ba7d134e0 SHA512 7023603668f540ecc0b35f3289377855c4c0df01e04a9af255f5c8031f568f6b76508bb3a7f0aba8e76a86b63eae423908c30f47258d6dee46bb23320c952701
diff --git a/dev-python/pylint/pylint-2.7.4.ebuild b/dev-python/pylint/pylint-2.7.4.ebuild
deleted file mode 100644
index 950aa6531269..000000000000
--- a/dev-python/pylint/pylint-2.7.4.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="https://www.logilab.org/project/pylint
- https://pypi.org/project/pylint/
- https://github.com/pycqa/pylint"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 sparc x86"
-IUSE="examples"
-
-# Mirror requirements from pylint/__pkginfo__.py
-RDEPEND="
- <dev-python/astroid-2.6[${PYTHON_USEDEP}]
- >=dev-python/astroid-2.5.2[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
- >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/six[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
-)
-
-distutils_enable_sphinx doc --no-autodoc
-distutils_enable_tests pytest
-
-python_test() {
- local skipped_tests=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- # Fails when graphviz is installed (?!)
- tests/test_import_graph.py::test_missing_graphviz
- )
- # Specify the test directory explicitly to avoid import file mismatches
- epytest tests ${skipped_tests[@]/#/--deselect }
-}
-
-python_install_all() {
- doman man/{pylint,pyreverse}.1
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}