summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-10-06 00:23:40 +0300
committerMart Raudsepp <leio@gentoo.org>2021-10-09 12:47:37 +0300
commit4166aabd1a51f65d7a29aba8a8df08f9c8258293 (patch)
treebc7bfbdb0a0a0c3d4ee80dea5e99ef7a34a44371
parentdev-python/sphinx-bootstrap-theme: block <setuptools-58 for 0.8.0 (diff)
downloadgentoo-4166aabd.tar.gz
gentoo-4166aabd.tar.bz2
gentoo-4166aabd.zip
gnome-extra/evolution-data-server: bump to 3.42.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--gnome-extra/evolution-data-server/Manifest1
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.42.0.ebuild155
-rw-r--r--profiles/package.mask4
3 files changed, 160 insertions, 0 deletions
diff --git a/gnome-extra/evolution-data-server/Manifest b/gnome-extra/evolution-data-server/Manifest
index 75437de7e058..b1126d05a0cf 100644
--- a/gnome-extra/evolution-data-server/Manifest
+++ b/gnome-extra/evolution-data-server/Manifest
@@ -1,2 +1,3 @@
DIST evolution-data-server-3.40.3.tar.xz 4625980 BLAKE2B 7b344c1bb279367c9eca136b9f4689f049ba126b9ffd6ba1a1a819c5f86db66bae4082ebab83c8895831e97a4ed4384bb923584146b6081ffbbc24c327d5f3d4 SHA512 ba5db9850d68c23ddc77e53ccb2500f613dcdc5689234b3365edbc97eb6e73c4f15c13df5dee0b2aab1d0af5a22d543c6aeb814c4abfe1dc652b46712c0e2e79
DIST evolution-data-server-3.40.4.tar.xz 4622640 BLAKE2B 93a4570da53fb34b496cd471e5daff07fa044ed5c230f7de85276ab9aacd0f2e6c6f749a0d63d076fc192e695f68a0c451a7a6573621ff5092cd5ea6a9302ee2 SHA512 664c2d41b6f212e6ddef554767ca651e4179ce861898cb11ed373f30473c2a1a3a47191ae504be7d38beb0e721782564b70f5f519a3184216a02be1bd89678b5
+DIST evolution-data-server-3.42.0.tar.xz 4614616 BLAKE2B 801e1a71c10af4f7c8b2e8478631ed76269170b01bb30dca296da7b151041981e0f45f9a69fe4873f503d0d38b7e6fdf50c6a7006d001af7d16663478a102b6e SHA512 44e4a45ac7779fd5a336aa84b8e23926cc861c1a3d1ca5629a4997a8783415eca1f6bdcef4fa6ed10e5417a64eef31dbe9edbf027954a653f4c22e25c90f16c1
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.42.0.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.42.0.ebuild
new file mode 100644
index 000000000000..42b2525574f3
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.42.0.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit cmake db-use flag-o-matic gnome2 systemd vala virtualx
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+# Note: explicitly "|| ( LGPL-2 LGPL-3 )", not "LGPL-2+".
+LICENSE="|| ( LGPL-2 LGPL-3 ) BSD Sleepycat"
+SLOT="0/63-26-20" # subslot = libcamel-1.2/libedataserver-1.2/libebook-1.2.so soname version
+
+IUSE="berkdb +gnome-online-accounts +gtk gtk-doc +introspection ipv6 ldap kerberos oauth vala +weather"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+# gdata-0.17.7 soft required for new gdata_feed_get_next_page_token API to handle more than 100 google tasks
+# berkdb needed only for migrating old addressbook data from <3.13 versions, bug #519512
+# glib-2.70 for build-time optional GPowerProfileMonitor
+gdata_depend=">=dev-libs/libgdata-0.17.7:="
+RDEPEND="
+ >=app-crypt/gcr-3.4
+ >=app-crypt/libsecret-0.5[crypt]
+ >=dev-db/sqlite-3.7.17:=
+ >=dev-libs/glib-2.70:2
+ >=dev-libs/libical-3.0.8:=[glib,introspection?]
+ >=dev-libs/libxml2-2
+ >=dev-libs/nspr-4.4:=
+ >=dev-libs/nss-3.9:=
+ >=net-libs/libsoup-2.58:2.4
+
+ dev-libs/icu:=
+ sys-libs/zlib:=
+ virtual/libiconv
+
+ berkdb? ( >=sys-libs/db-4:= )
+ gtk? (
+ >=app-crypt/gcr-3.4[gtk]
+ >=x11-libs/gtk+-3.16:3
+ >=media-libs/libcanberra-0.25[gtk3]
+ )
+ oauth? (
+ >=dev-libs/json-glib-1.0.4
+ >=net-libs/webkit-gtk-2.28.0:4
+ ${gdata_depend}
+ )
+ gnome-online-accounts? (
+ >=net-libs/gnome-online-accounts-3.8:=
+ ${gdata_depend} )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+ kerberos? ( virtual/krb5:= )
+ ldap? ( >=net-nds/openldap-2:= )
+ weather? ( >=dev-libs/libgweather-3.10:2= )
+"
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend)
+ net-libs/libsoup:2.4[vala]
+ dev-libs/libical[vala]
+ oauth? ( dev-libs/libgdata[vala] )
+ gnome-online-accounts? ( dev-libs/libgdata[vala] )
+ )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gperf
+ gtk-doc? ( >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Some tests fail due to missing locales.
+# Also, dbus tests are flaky, bugs #397975 #501834
+# It looks like a nightmare to disable those for now.
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare call
+src_prepare() {
+ use vala && vala_src_prepare
+ cmake_src_prepare
+ gnome2_src_prepare
+
+ eapply "${FILESDIR}"/3.36.5-gtk-doc-1.32-compat.patch
+
+ # Make CMakeLists versioned vala enabled
+ sed -e "s;\(find_program(VALAC\) valac);\1 ${VALAC});" \
+ -e "s;\(find_program(VAPIGEN\) vapigen);\1 ${VAPIGEN});" \
+ -i "${S}"/CMakeLists.txt || die
+}
+
+src_configure() {
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ use berkdb && append-cppflags "-I$(db_includedir)"
+
+ local google_enable
+ if use oauth || use gnome-online-accounts; then
+ google_enable="ON"
+ else
+ google_enable="OFF"
+ fi
+
+ # phonenumber does not exist in tree
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DENABLE_GTK_DOC=$(usex gtk-doc)
+ -DWITH_PRIVATE_DOCS=$(usex gtk-doc)
+ -DENABLE_SCHEMAS_COMPILE=OFF
+ -DENABLE_INTROSPECTION=$(usex introspection)
+ -DWITH_KRB5=$(usex kerberos)
+ -DWITH_KRB5_INCLUDES=$(usex kerberos "${EPREFIX}"/usr "")
+ -DWITH_KRB5_LIBS=$(usex kerberos "${EPREFIX}"/usr/$(get_libdir) "")
+ -DWITH_OPENLDAP=$(usex ldap)
+ -DWITH_PHONENUMBER=OFF
+ -DENABLE_SMIME=ON
+ -DENABLE_GTK=$(usex gtk)
+ -DENABLE_CANBERRA=$(usex gtk)
+ -DENABLE_OAUTH2=$(usex oauth)
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_GOA=$(usex gnome-online-accounts)
+ -DWITH_LIBDB=$(usex berkdb "${EPREFIX}"/usr OFF)
+ # ENABLE_BACKTRACES requires libdwarf ?
+ -DENABLE_IPV6=$(usex ipv6)
+ -DENABLE_WEATHER=$(usex weather)
+ -DENABLE_GOOGLE=${google_enable}
+ -DENABLE_LARGEFILE=ON
+ -DENABLE_VALA_BINDINGS=$(usex vala)
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ virtx cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ if use ldap; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/calentry.schema
+ dosym ../../../usr/share/${PN}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
+ fi
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 69e159a28c3b..bef9607da4dc 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -33,6 +33,10 @@
#--- END OF EXAMPLES ---
+# Gnome Team <gnome@gentoo.org> (2021-10-09)
+# GNOME 41 mask, bug #812986
+>=gnome-extra/evolution-data-server-3.41
+
# Fabian Groffen <grobian@gentoo.org> (2021-10-03)
# Masked for erratic behaviour
# https://bugs.exim.org/show_bug.cgi?id=2813