summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-18 08:05:20 +0100
committerSam James <sam@gentoo.org>2023-04-18 08:05:20 +0100
commit416abeba80edf7905accdcfd9bfbcbc707709b46 (patch)
tree59342296b15f1c7f6ae011cbbccec106e20232c1
parentsci-mathematics/4ti2: add github upstream metadata (diff)
downloadgentoo-416abeba80edf7905accdcfd9bfbcbc707709b46.tar.gz
gentoo-416abeba80edf7905accdcfd9bfbcbc707709b46.tar.bz2
gentoo-416abeba80edf7905accdcfd9bfbcbc707709b46.zip
sci-mathematics/4ti2: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/895420 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-mathematics/4ti2/4ti2-1.6.7-r1.ebuild7
-rw-r--r--sci-mathematics/4ti2/files/4ti2-1.6.7-gcc13.patch21
2 files changed, 26 insertions, 2 deletions
diff --git a/sci-mathematics/4ti2/4ti2-1.6.7-r1.ebuild b/sci-mathematics/4ti2/4ti2-1.6.7-r1.ebuild
index 887469dd15eb..fa3572550200 100644
--- a/sci-mathematics/4ti2/4ti2-1.6.7-r1.ebuild
+++ b/sci-mathematics/4ti2/4ti2-1.6.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,10 @@ RDEPEND="
dev-libs/gmp:0=[cxx(+)]"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${PN}-1.3.2-gold.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.2-gold.patch
+ "${FILESDIR}"/${P}-gcc13.patch
+)
src_prepare() {
default
diff --git a/sci-mathematics/4ti2/files/4ti2-1.6.7-gcc13.patch b/sci-mathematics/4ti2/files/4ti2-1.6.7-gcc13.patch
new file mode 100644
index 000000000000..32f7c1a42b34
--- /dev/null
+++ b/sci-mathematics/4ti2/files/4ti2-1.6.7-gcc13.patch
@@ -0,0 +1,21 @@
+https://bugs.gentoo.org/895420
+https://github.com/4ti2/4ti2/commit/c024db44f43593fbfe9d8d51f035db7a605d1fa6
+
+From c024db44f43593fbfe9d8d51f035db7a605d1fa6 Mon Sep 17 00:00:00 2001
+From: Jan Engelhardt <jengelh@inai.de>
+Date: Tue, 28 Mar 2023 00:33:03 +0200
+Subject: [PATCH] build: resolve missing includes showing on gcc-13
+
+../../src/zsolve/VectorArrayAPI.hpp: In function 'void _4ti2_zsolve_::convert(const T1&, T2&) [with T1 = long int; T2 = int]':
+../../src/zsolve/VectorArrayAPI.hpp:79:14: error: 'INT32_MIN' was not declared in this scope; did you mean 'INT_MIN'?
+--- a/src/zsolve/VectorArrayAPI.hpp
++++ b/src/zsolve/VectorArrayAPI.hpp
+@@ -27,6 +27,7 @@ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+ #include "zsolve/VectorArray.hpp"
+ #include "zsolve/Exception.h"
+ #include <fstream>
++#include <cstdint>
+ #include <cstdlib>
+
+ namespace _4ti2_zsolve_ {
+