summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-30 11:20:08 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-30 11:20:08 +0200
commit416d9a6613ba91327f6e372476aefd5ca5408ef4 (patch)
tree8fafacbcdcc501786ad4793c85001ff936e429eb
parentnet-analyzer/fprobe: drop 1.1-r3 (diff)
downloadgentoo-416d9a66.tar.gz
gentoo-416d9a66.tar.bz2
gentoo-416d9a66.zip
net-analyzer/fprobe: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-analyzer/fprobe/files/fprobe-1.1-setgroups.patch11
-rw-r--r--net-analyzer/fprobe/fprobe-1.1-r5.ebuild (renamed from net-analyzer/fprobe/fprobe-1.1-r4.ebuild)20
2 files changed, 11 insertions, 20 deletions
diff --git a/net-analyzer/fprobe/files/fprobe-1.1-setgroups.patch b/net-analyzer/fprobe/files/fprobe-1.1-setgroups.patch
index 803a2a9ce43a..948c6fee29c1 100644
--- a/net-analyzer/fprobe/files/fprobe-1.1-setgroups.patch
+++ b/net-analyzer/fprobe/files/fprobe-1.1-setgroups.patch
@@ -4,15 +4,12 @@ Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
--- a/src/fprobe.c
+++ b/src/fprobe.c
-@@ -1541,10 +1541,10 @@
- }
-
+@@ -1543,7 +1543,7 @@
if (pw) {
- if (setgroups(0, NULL) < 0) {
- my_log(LOG_CRIT, "setgroups: %s", strerror(errno));
+ if (setgroups(0, NULL) < 0) {
+ my_log(LOG_CRIT, "setgroups: %s", strerror(errno));
- exit(1);
+ //exit(1);
- }
+ }
if (setregid(pw->pw_gid, pw->pw_gid)) {
my_log(LOG_CRIT, "setregid(%u): %s", pw->pw_gid, strerror(errno));
- exit(1);
diff --git a/net-analyzer/fprobe/fprobe-1.1-r4.ebuild b/net-analyzer/fprobe/fprobe-1.1-r5.ebuild
index 76646bcf6a10..1aee1c4aa4f3 100644
--- a/net-analyzer/fprobe/fprobe-1.1-r4.ebuild
+++ b/net-analyzer/fprobe/fprobe-1.1-r5.ebuild
@@ -1,24 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="libpcap-based tool to collect network traffic data and emit it as NetFlow flows"
HOMEPAGE="http://fprobe.sourceforge.net"
-LICENSE="GPL-2"
-
SRC_URI="mirror://sourceforge/fprobe/${P}.tar.bz2"
+
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-
IUSE="debug messages"
-DEPEND="
- net-libs/libpcap
-"
-RDEPEND="
- ${DEPEND}
-"
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
PATCHES=(
"${FILESDIR}"/fprobe-1.1-pidfile-sanity.patch
"${FILESDIR}"/fprobe-1.1-setgroups.patch
@@ -30,8 +26,6 @@ src_configure() {
$(use_enable messages)
}
-DOCS=( AUTHORS NEWS README TODO )
-
src_install() {
default