summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2022-05-21 15:36:27 -0500
committerErik Mackdanz <stasibear@gentoo.org>2022-05-21 15:36:55 -0500
commit4170fbb616afb6afb22fe06a50976a8d2a1fb033 (patch)
tree7fd747ec4017ca83eaf560800aa0c562ee2c05d0
parentnet-libs/libnpupnp: bump 4.2.2 (diff)
downloadgentoo-4170fbb616afb6afb22fe06a50976a8d2a1fb033.tar.gz
gentoo-4170fbb616afb6afb22fe06a50976a8d2a1fb033.tar.bz2
gentoo-4170fbb616afb6afb22fe06a50976a8d2a1fb033.zip
media-sound/upmpdcli: bump to 1.5.17
Signed-off-by: Erik Mackdanz <stasibear@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
-rw-r--r--media-sound/upmpdcli/Manifest1
-rw-r--r--media-sound/upmpdcli/upmpdcli-1.5.17.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-sound/upmpdcli/Manifest b/media-sound/upmpdcli/Manifest
index 5781dfb77988..af9f90d165f7 100644
--- a/media-sound/upmpdcli/Manifest
+++ b/media-sound/upmpdcli/Manifest
@@ -1 +1,2 @@
DIST upmpdcli-1.5.13.tar.gz 579569 BLAKE2B 30af7f455c0564e46c627217853a230bdabd0209baaa62b247388814af8005ecd0125de242c98cc20bef28adc548b5e83fa61d797535daa00cf180cad0fe0217 SHA512 bf61f7befe5fd64cdeed94f7d82965991d95abf8f8f96b044934d64aa55c887b7f4cdbc48f72a4843a5b6a145d9ccae6166e38710ce2015ccba18ac13c365ac6
+DIST upmpdcli-1.5.17.tar.gz 585821 BLAKE2B dfd47d710751540743f5df38975e2775ac99355781c7d7bf8b50543148bc22aa85f4f851a5628291f11474342caec99ecfa664cd701fbe13c46be1d56cc6b042 SHA512 caaba9d6ee8564e9464f19c9462e2fe4ed917270a9a66a9608895ddc8e060cefa339749ffc284d83a05be78571241e1c0ee74c4b0058bda8c5b1d8ebbaf248a1
diff --git a/media-sound/upmpdcli/upmpdcli-1.5.17.ebuild b/media-sound/upmpdcli/upmpdcli-1.5.17.ebuild
new file mode 100644
index 000000000000..61ec5aab1fe0
--- /dev/null
+++ b/media-sound/upmpdcli/upmpdcli-1.5.17.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="UPnP Media Renderer front-end for MPD, the Music Player Daemon"
+HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli/index.html"
+LICENSE="GPL-2"
+
+SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="thirdparty"
+
+DEPEND="
+ dev-libs/jsoncpp
+ media-libs/libmpdclient
+ net-libs/libmicrohttpd
+ net-libs/libupnpp
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/upmpdcli
+ acct-user/upmpdcli
+ app-misc/recoll
+ thirdparty? ( dev-python/requests )
+"
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit systemd/upmpdcli.service
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This package no longer assumes that upmpdcli is driving an"
+ einfo "mpd instance on the same host (https://bugs.gentoo.org/670130)."
+ einfo "Probably it is though, so be sure your mpd is built with"
+ einfo "USE=curl."
+}