summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-16 13:42:05 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-16 13:50:43 +0200
commit4171bfcb004899aa0e96aad951f19a13f1d325c3 (patch)
tree1e0b22e543bb5ce4a783f0010615ac69753297d2
parentdev-scheme: use dostrip instead of RESTRICT (diff)
downloadgentoo-4171bfcb004899aa0e96aad951f19a13f1d325c3.tar.gz
gentoo-4171bfcb004899aa0e96aad951f19a13f1d325c3.tar.bz2
gentoo-4171bfcb004899aa0e96aad951f19a13f1d325c3.zip
dev-scheme/guile-zstd: do not strip guile bytecode
Bug: https://bugs.gentoo.org/905898 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-scheme/guile-zstd/guile-zstd-0.1.1-r1.ebuild (renamed from dev-scheme/guile-zstd/guile-zstd-0.1.1.ebuild)13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-scheme/guile-zstd/guile-zstd-0.1.1.ebuild b/dev-scheme/guile-zstd/guile-zstd-0.1.1-r1.ebuild
index efd8811afedd..7d00f87e4450 100644
--- a/dev-scheme/guile-zstd/guile-zstd-0.1.1.ebuild
+++ b/dev-scheme/guile-zstd/guile-zstd-0.1.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,8 @@ inherit autotools
DESCRIPTION="GNU Guile bindings to the zstd compression library"
HOMEPAGE="https://notabug.org/guile-zstd/guile-zstd/"
-SRC_URI="https://notabug.org/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://notabug.org/${PN}/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
S="${WORKDIR}"/${PN}
LICENSE="GPL-3+"
@@ -46,3 +47,11 @@ src_prepare() {
eautoreconf
}
+
+src_install() {
+ default
+
+ # Workaround llvm-strip problem of mangling guile ELF debug
+ # sections: https://bugs.gentoo.org/905898
+ dostrip -x "/usr/$(get_libdir)/guile"
+}