summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-28 04:28:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-28 04:37:15 +0200
commit41a8eaf0de42274354c3e1cdb6b77d3127e27c8c (patch)
treebe06842025e4239f07c5cd3d9d2c6117412a3603
parentdev-python/sphinx-gallery: Bump to 0.16.0 (diff)
downloadgentoo-41a8eaf0de42274354c3e1cdb6b77d3127e27c8c.tar.gz
gentoo-41a8eaf0de42274354c3e1cdb6b77d3127e27c8c.tar.bz2
gentoo-41a8eaf0de42274354c3e1cdb6b77d3127e27c8c.zip
dev-python/agate: Bump to 1.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/agate/Manifest1
-rw-r--r--dev-python/agate/agate-1.10.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index c8acd0f2c61e..e1fa3980abe4 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1 +1,2 @@
+DIST agate-1.10.0.tar.gz 202845 BLAKE2B da462a47d8b33e6b5948bc16a9c236ee62c92d56f49df8a7e60cebc84b2d4d828f986f6f0975d24d1d513e1e8023dd5e570f77ff6ae233533ab1ac3c512fac81 SHA512 37e09f1fcccd5df9183cfd32f13bf23efad7987a3d71600e52b1b3bc9de8669640aa50f045c975c0fc8958cbe9df193e17f0ea52c1933782cca95ac267f794f9
DIST agate-1.9.1.tar.gz 202303 BLAKE2B a5e62ca5fdf8dc6e1b7393da3efa0432a2d7a89bcb2af744458ae04446ea85941968f1ee75facc6b29de9fdec92f9432d2b939392edbfadc5c0598a91feb9f76 SHA512 f8bbe9ed24c786063a1d99aa408a2e5b4841dd9d804004b8c74a272d564432013e0ddebc5325e73893c53a60636d64f27f2e64ad624a468a070cf6a8833b8620
diff --git a/dev-python/agate/agate-1.10.0.ebuild b/dev-python/agate/agate-1.10.0.ebuild
new file mode 100644
index 000000000000..baca934b9901
--- /dev/null
+++ b/dev-python/agate/agate-1.10.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="
+ https://github.com/wireservice/agate/
+ https://pypi.org/project/agate/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/cssselect-0.9.1[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)