summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-07-02 15:55:55 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-07-02 15:55:55 +0200
commit41a96591e7061ad6a3d4319d97b718c3ed01b246 (patch)
treeb5adfb9dd2cb45795501c96fdf448005ef774d71
parentnet-misc/freerdp: replace distfile for 2.1.2 (diff)
downloadgentoo-41a96591.tar.gz
gentoo-41a96591.tar.bz2
gentoo-41a96591.zip
media-libs/glm: Version bump to 0.9.9.8
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--media-libs/glm/Manifest1
-rw-r--r--media-libs/glm/glm-0.9.9.8.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-libs/glm/Manifest b/media-libs/glm/Manifest
index f75ae6b2e52e..e165587e7d25 100644
--- a/media-libs/glm/Manifest
+++ b/media-libs/glm/Manifest
@@ -1,2 +1,3 @@
DIST glm-0.9.9.5.tar.gz 4578601 BLAKE2B 9ce4dc7e638a651f958e2e0e1bfa0da121aefc382579838bfd810952bb8f4253e17caa6d743de713c86a4e8bd5f1afa38f8162e5f2d98ab141d94574d1103d40 SHA512 3b329acf5144aab1c0f47f8045d34e097699bd6685118ad8322c5ce23afdcb44ba2bb07e49301db06355b8eef7d4340b72251d55e113b533740d1e6ef6609911
DIST glm-0.9.9.7.tar.gz 4357077 BLAKE2B 59746a8775e0fc20fe8a8c3ae01c48841066d6092ce3cd7fa93bbf29f5247c42645bc920a3dbf3f0b4b61eb1e47f46514d9cd98c4e6df133ced0072ba6a570ee SHA512 9c557788d6382777317c94f8b30bc3df7e533877705514fa5d384f97b076d6bc750e841acbecdec8113e21af07bd8850159f5f1e079aaa2cde25540b480f983b
+DIST glm-0.9.9.8.tar.gz 4368032 BLAKE2B 41e4d4a9fbd75c6c6717e43b6a6ae09bb7da3b4b2ee7c5b04308f3aa875b306638b638aca3e457c039845c489fcf0716a080ec2166bf5e9db93c25944f4ba81a SHA512 9484b0c12175414237c5b9486a2990099b1cb727e442f25ecda18b081aa661f7e92a44481f642989553cd3da7992a773441ee5688991bd539ce19fb66a5ce9e8
diff --git a/media-libs/glm/glm-0.9.9.8.ebuild b/media-libs/glm/glm-0.9.9.8.ebuild
new file mode 100644
index 000000000000..dcd6a2c59118
--- /dev/null
+++ b/media-libs/glm/glm-0.9.9.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="OpenGL Mathematics"
+HOMEPAGE="http://glm.g-truc.net/"
+SRC_URI="https://github.com/g-truc/glm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( HappyBunny MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_avx cpu_flags_x86_avx2"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.9.6-simd.patch
+)
+
+src_prepare() {
+ sed \
+ -e "s:@CMAKE_INSTALL_PREFIX@:${EPREFIX}/usr:" \
+ -e "s:@GLM_VERSION@:0.9.9:" \
+ "${FILESDIR}"/glm.pc.in \
+ > glm.pc
+ cmake_src_prepare
+}
+
+src_configure() {
+ if use test; then
+ local mycmakeargs=(
+ -DGLM_TEST_ENABLE=ON
+ -DGLM_TEST_ENABLE_SIMD_SSE2="$(usex cpu_flags_x86_sse2 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_SSE3="$(usex cpu_flags_x86_sse3 ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX="$(usex cpu_flags_x86_avx ON OFF)"
+ -DGLM_TEST_ENABLE_SIMD_AVX2="$(usex cpu_flags_x86_avx2 ON OFF)"
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ doheader -r glm
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins glm.pc
+ dodoc readme.md manual.md
+}