summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-23 22:36:59 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-23 23:51:25 -0600
commit41abe63a0f7c43f3770147a550c9f2087cfbe330 (patch)
treeefd061e41ea9147a23c941a39ce1734ad121819f
parentdev-python/neutron-lib: 1.13.0 bup (diff)
downloadgentoo-41abe63a0f7c43f3770147a550c9f2087cfbe330.tar.gz
gentoo-41abe63a0f7c43f3770147a550c9f2087cfbe330.tar.bz2
gentoo-41abe63a0f7c43f3770147a550c9f2087cfbe330.zip
dev-python/jsonpatch: 1.21 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/jsonpatch/Manifest1
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.21.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index 397ea6909512..6fbe40c34e4b 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1,2 +1,3 @@
DIST jsonpatch-1.13.tar.gz 15119 BLAKE2B 70ddb570451ac1f3d218de0f79f0a639eb922ce72084cf3bc7e89a3efedb85c6238293bf59608a51f07c33358dc0488550f982f122e89e2414ddfce26fe08c1f SHA512 23f0c92c2c8834d5e3129e9ba78ece7da2646dd60d5b0522b0f09d83e20057ef7517042e5ee8547804185d3ce23cff394c8fe78df93fad7999fae12cc5467a45
DIST jsonpatch-1.15.tar.gz 15544 BLAKE2B 1b9facd2a88a997356aeace8ddec9011f4f3c4df812fb157cd22f1210ac2e2502e8b9e18e02ea477c869758cdfc1dd0b6b4c8d76ce59ffdd68d4db14c550b572 SHA512 c5df880764b14a2fb60bb46e319bf006644ce1472d0413cf08ad151cf386e5be9fec197fd9efe0bfc3aa22dadf4078344c11211c1e8a3d5cc3ddcb998795dc91
+DIST jsonpatch-1.21.tar.gz 15208 BLAKE2B 88af93bfd7c317319d958bc3386f9551279af2fa9631c24c49231eb67398fd80f298e26957f232c9705219d4fa7033bb62f98b5d5391f6eb9f53113a1d351876 SHA512 dc902b750241833a68612430f07007080ed56dce8a7a4bdd1c042f944cd6cfdc03f4b422cc6bed6bc3b21ea390c5a281cd08181e27d6b57fc5fb657787c1d740
diff --git a/dev-python/jsonpatch/jsonpatch-1.21.ebuild b/dev-python/jsonpatch/jsonpatch-1.21.ebuild
new file mode 100644
index 000000000000..b1dcf7799db4
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.21.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+RESTRICT="test"
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches according to
+ http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_test() {
+ "${PYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${PYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}