summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-14 02:10:08 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-04-15 09:38:50 +0300
commit41c51365112a65e3638e3d8469f20584419424b0 (patch)
treef1d7f215ce2021ac694b882c46da74db2c4d3182
parentapp-i18n/kinput2: fix build with -native-symlinks (diff)
downloadgentoo-41c51365112a65e3638e3d8469f20584419424b0.tar.gz
gentoo-41c51365112a65e3638e3d8469f20584419424b0.tar.bz2
gentoo-41c51365112a65e3638e3d8469f20584419424b0.zip
app-misc/oneko: fix build with -native-symlinks
ebuild used an ld wrapper to try to work around this, but while this removed the QA notice it'd still fail on gcc (bug #729856). Wrapper could also cause an infinite loop if user sets LD=ld. Closes: https://bugs.gentoo.org/729856 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-misc/oneko/oneko-1.2_p6_p14-r1.ebuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/app-misc/oneko/oneko-1.2_p6_p14-r1.ebuild b/app-misc/oneko/oneko-1.2_p6_p14-r1.ebuild
index 262843e5b3d9..6e1677c1aeee 100644
--- a/app-misc/oneko/oneko-1.2_p6_p14-r1.ebuild
+++ b/app-misc/oneko/oneko-1.2_p6_p14-r1.ebuild
@@ -28,7 +28,7 @@ DEPEND="
BDEPEND="
app-text/rman
x11-misc/gccmakedep
- x11-misc/imake
+ >=x11-misc/imake-1.0.8-r1
"
PATCHES=(
"${FILESDIR}"/${P/_p*}-include.patch
@@ -41,20 +41,17 @@ src_prepare() {
done
default
-
- printf '#!/bin/sh\n%s ${*}\n' "$(tc-getLD)" > "${T}"/ld
- chmod +x "${T}"/ld
- export PATH="${T}:${PATH}"
}
src_configure() {
- xmkmf -a || die
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
}
src_compile() {
emake \
CC="$(tc-getCC)" \
- CCOPTIONS="${CFLAGS}" \
+ CDEBUGFLAGS="${CFLAGS}" \
EXTRA_LDOPTIONS="${LDFLAGS}"
}