summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-01-28 13:37:23 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-01-29 11:53:08 -0800
commit41e267420d69b0600dfcc6bb74fb92943fd60bcd (patch)
treefe3bfd603330493360d695caad8a18941602c8e8
parentdev-python/dulwich-0.19.15: Version bump, add py38 (diff)
downloadgentoo-41e26742.tar.gz
gentoo-41e26742.tar.bz2
gentoo-41e26742.zip
dev-python/wrapt-1.11.2-r1: Revbump, add py38, use new eclass funcs
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/wrapt/wrapt-1.11.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/wrapt/wrapt-1.11.2-r1.ebuild b/dev-python/wrapt/wrapt-1.11.2-r1.ebuild
new file mode 100644
index 000000000000..46b0288179ff
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.11.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+python_compile() {
+ local WRAPT_EXTENSIONS=true
+
+ distutils-r1_python_compile
+}