summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-08 09:18:52 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-08 09:25:23 +0100
commit41fe8b54533f7ae8c5734ecf6c1dc55a52fbfbd5 (patch)
treece796ac97cf303eeadcb464b148f0954df4ba6e9
parentdev-python/pyfakefs: Bump to 4.5.2 (diff)
downloadgentoo-41fe8b54533f7ae8c5734ecf6c1dc55a52fbfbd5.tar.gz
gentoo-41fe8b54533f7ae8c5734ecf6c1dc55a52fbfbd5.tar.bz2
gentoo-41fe8b54533f7ae8c5734ecf6c1dc55a52fbfbd5.zip
dev-python/rich: Bump to 10.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-10.13.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 83214eb1c4e5..06223c6c36c3 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1 +1,2 @@
DIST rich-10.12.0.tar.gz 16265099 BLAKE2B c2249be5a5008e3e9fd5c301b10d7bc544e4805d4762e87481aa31716e38eb3cb2b81ce80f201fc0d3961574136f47b7b374d6bc7d18e4f55f1f757a7e17e5a2 SHA512 bb42ff24c9eeeae548a6e222ecc03f8b46d763c4b022964bd8fb11517f1a23a7aaa82a2155d5cd3d29cdd1af5fab6cc4f26840a84ce5e26dd740f8706961ce1f
+DIST rich-10.13.0.tar.gz 16277448 BLAKE2B e33bca376e1a5b82d0648c7bdda9ce30930b7c095cd8272b573f52dcb056a21be35fb0ef83c939e7feeb458eb4efb7767bf98706a4c58fc134627a0b0f3aa68d SHA512 23ea811fbaa8002416530975fe79c62b42d3c79806d312c172351f632864356be77063d5dc0fe0243d78479fb31a87433a432b115f5cf570f7c6e44c6f773ff0
diff --git a/dev-python/rich/rich-10.13.0.ebuild b/dev-python/rich/rich-10.13.0.ebuild
new file mode 100644
index 000000000000..05ddc3dab2e6
--- /dev/null
+++ b/dev-python/rich/rich-10.13.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}