summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-06-28 22:20:58 +0200
committerPacho Ramos <pacho@gentoo.org>2016-06-28 22:29:54 +0200
commit420592d9109d80a68a4694a48076dcf8b8a7327c (patch)
tree329b35c8bc0a4d1b9f3406a0577fbc8386492ae6
parentnet-wireless/gnome-bluetooth: Drop old (diff)
downloadgentoo-420592d9.tar.gz
gentoo-420592d9.tar.bz2
gentoo-420592d9.zip
net-wireless/gnome-bluetooth: Version bump
Package-Manager: portage-2.3.0_rc1
-rw-r--r--net-wireless/gnome-bluetooth/Manifest1
-rw-r--r--net-wireless/gnome-bluetooth/gnome-bluetooth-3.20.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-wireless/gnome-bluetooth/Manifest b/net-wireless/gnome-bluetooth/Manifest
index 5e1e8770ac46..2b05b6a72659 100644
--- a/net-wireless/gnome-bluetooth/Manifest
+++ b/net-wireless/gnome-bluetooth/Manifest
@@ -1 +1,2 @@
DIST gnome-bluetooth-3.18.3.tar.xz 793460 SHA256 e481b70423e52adc3c3aa919eeb033b47f9cd1598d6c0c7f384c0bd10f4e8ce3 SHA512 8d0c6d6d1344d297723607de2770ec31544e910e91a9e927ac5ee5eb41862d3b961b225a0fb37b929c5167863d352e54cbbb48a762a94146528fee8a8ebd16f2 WHIRLPOOL 4b071104f825d9fd50b5f8941e7555929682b730ed11b1626a62879c42b4e9b4e7309feb88d33d9f4ee9c4727f338308e63248367888bc033926ec66e52cd918
+DIST gnome-bluetooth-3.20.0.tar.xz 794480 SHA256 93b3ca16b348a168d044b3f777049b7dba2a9292c4adb2751a771e3bc5e4eb53 SHA512 6100a612bd395c95ac47a55e80272e745ff8e640cc769060bd312b707e4d921bb5549deb2ef91845f1e5340f6e454ce0898624c0c67f4f534c6c482bc898834f WHIRLPOOL 423381791b14851ec8611e58653635c7aa777e3de53edf44f63c2112ba65816f708d36098782298f7e4e77a23e0ed1bfe768ebd6777988cbfc7b850b86d0f57e
diff --git a/net-wireless/gnome-bluetooth/gnome-bluetooth-3.20.0.ebuild b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.20.0.ebuild
new file mode 100644
index 000000000000..2be15fda16f1
--- /dev/null
+++ b/net-wireless/gnome-bluetooth/gnome-bluetooth-3.20.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2 udev user
+
+DESCRIPTION="Bluetooth graphical utilities integrated with GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeBluetooth"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="2/13" # subslot = libgnome-bluetooth soname version
+IUSE="debug +introspection"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.38:2
+ media-libs/libcanberra[gtk3]
+ >=x11-libs/gtk+-3.12:3[introspection?]
+ x11-libs/libnotify
+ virtual/udev
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=net-wireless/bluez-5
+"
+DEPEND="${COMMON_DEPEND}
+ !net-wireless/bluez-gnome
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.40.0
+ dev-util/itstool
+ virtual/libudev
+ virtual/pkgconfig
+ x11-proto/xproto
+"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+pkg_setup() {
+ enewgroup plugdev
+}
+
+src_prepare() {
+ # Regenerate gdbus-codegen files to allow using any glib version; bug #436236
+ # https://bugzilla.gnome.org/show_bug.cgi?id=758096
+ rm -v lib/bluetooth-client-glue.{c,h} || die
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable introspection) \
+ --enable-documentation \
+ --disable-desktop-update \
+ --disable-icon-update \
+ --disable-static
+}
+
+src_install() {
+ gnome2_src_install
+ udev_dorules "${FILESDIR}"/61-${PN}.rules
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! has_version sys-auth/consolekit[acl] && ! has_version sys-apps/systemd[acl] ; then
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to control bluetooth transmitter."
+ fi
+}