summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-03-21 01:17:05 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-03-21 01:44:13 -0400
commit42177c71dd144e397935801799dd37d4e416fc47 (patch)
tree814f11d9784ed86ed3aaebff5d811bce6dfbde37
parentdev-python/recommonmark: Fix HOMEPAGE and distfile suffix (diff)
downloadgentoo-42177c71.tar.gz
gentoo-42177c71.tar.bz2
gentoo-42177c71.zip
games-emulation/pcsx2: update live, add IUSE=backtrace
Unsure about the USE choice, library is scarcely used and so no real point of reference. Considered a generic USE=debug, but going with a described local USE. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-emulation/pcsx2/metadata.xml1
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/games-emulation/pcsx2/metadata.xml b/games-emulation/pcsx2/metadata.xml
index efa1131e61ab..cf7d628cd86c 100644
--- a/games-emulation/pcsx2/metadata.xml
+++ b/games-emulation/pcsx2/metadata.xml
@@ -14,6 +14,7 @@
<name>Gentoo Games Project</name>
</maintainer>
<use>
+ <flag name="backtrace">Display a backtrace on crash using <pkg>sys-libs/libbacktrace</pkg></flag>
<flag name="sndio">Enable support for the <pkg>media-sound/sndio</pkg> backend</flag>
<flag name="vulkan">Enable support for Vulkan</flag>
</use>
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index be5cf31b436b..5d05ef3be008 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -35,7 +35,7 @@ LICENSE="
GPL-3+ Apache-2.0 BSD BSD-2 BSD-4 Boost-1.0 CC0-1.0 GPL-2+
ISC LGPL-2.1+ LGPL-3+ MIT OFL-1.1 ZLIB public-domain"
SLOT="0"
-IUSE="alsa cpu_flags_x86_sse4_1 jack pulseaudio sndio test vulkan wayland"
+IUSE="alsa backtrace cpu_flags_x86_sse4_1 jack pulseaudio sndio test vulkan wayland"
REQUIRED_USE="cpu_flags_x86_sse4_1" # dies at runtime if no support
RESTRICT="!test? ( test )"
@@ -61,6 +61,7 @@ RDEPEND="
virtual/libudev:=
x11-libs/libXrandr
alsa? ( media-libs/alsa-lib )
+ backtrace? ( sys-libs/libbacktrace )
jack? ( virtual/jack )
pulseaudio? ( media-libs/libpulse )
sndio? ( media-sound/sndio:= )
@@ -149,6 +150,7 @@ src_configure() {
use vulkan && append-flags -fno-strict-aliasing
local mycmakeargs=(
+ $(cmake_use_find_package backtrace Libbacktrace)
-DBUILD_SHARED_LIBS=no
-DDISABLE_BUILD_DATE=yes
-DENABLE_TESTS=$(usex test)