summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <stha09@googlemail.com>2019-11-19 16:59:08 +0100
committerMike Gilbert <floppym@gentoo.org>2019-11-20 14:28:17 -0500
commit421b6f443ceceb7f50d1802845c0a169c7257d1e (patch)
treefa47f7fb99f7ffdfd377734469294cf98e8d86a3
parentwww-client/chromium: stable channel bump to 78.0.3904.108 (diff)
downloadgentoo-421b6f443ceceb7f50d1802845c0a169c7257d1e.tar.gz
gentoo-421b6f443ceceb7f50d1802845c0a169c7257d1e.tar.bz2
gentoo-421b6f443ceceb7f50d1802845c0a169c7257d1e.zip
media-libs/libvpx: fix building on ppc
Closes: https://bugs.gentoo.org/694368 Thanks-to: ernsteiswuerfel <erhard_f@mailbox.org> Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Stephan Hartmann <stha09@googlemail.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13714
-rw-r--r--media-libs/libvpx/libvpx-1.7.0.ebuild3
-rw-r--r--media-libs/libvpx/libvpx-1.8.0-r1.ebuild3
-rw-r--r--media-libs/libvpx/libvpx-1.8.0.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/media-libs/libvpx/libvpx-1.7.0.ebuild b/media-libs/libvpx/libvpx-1.7.0.ebuild
index 877d221cedb9..752360e5cbe5 100644
--- a/media-libs/libvpx/libvpx-1.7.0.ebuild
+++ b/media-libs/libvpx/libvpx-1.7.0.ebuild
@@ -95,6 +95,9 @@ multilib_src_configure() {
x86_64*) export AS=yasm;;
esac
+ # powerpc toolchain is not recognized anymore, #694368
+ [[ ${CHOST} == powerpc-* ]] && myconfargs+=( --force-target=generic-gnu )
+
# Build with correct toolchain.
tc-export CC CXX AR NM
# Link with gcc by default, the build system should override this if needed.
diff --git a/media-libs/libvpx/libvpx-1.8.0-r1.ebuild b/media-libs/libvpx/libvpx-1.8.0-r1.ebuild
index 9c2b048cea49..f0bd95847496 100644
--- a/media-libs/libvpx/libvpx-1.8.0-r1.ebuild
+++ b/media-libs/libvpx/libvpx-1.8.0-r1.ebuild
@@ -84,6 +84,9 @@ multilib_src_configure() {
x86_64*) export AS=yasm;;
esac
+ # powerpc toolchain is not recognized anymore, #694368
+ [[ ${CHOST} == powerpc-* ]] && myconfargs+=( --force-target=generic-gnu )
+
# Build with correct toolchain.
tc-export CC CXX AR NM
# Link with gcc by default, the build system should override this if needed.
diff --git a/media-libs/libvpx/libvpx-1.8.0.ebuild b/media-libs/libvpx/libvpx-1.8.0.ebuild
index 5d7954ec89c1..a05ed4eb72ff 100644
--- a/media-libs/libvpx/libvpx-1.8.0.ebuild
+++ b/media-libs/libvpx/libvpx-1.8.0.ebuild
@@ -96,6 +96,9 @@ multilib_src_configure() {
x86_64*) export AS=yasm;;
esac
+ # powerpc toolchain is not recognized anymore, #694368
+ [[ ${CHOST} == powerpc-* ]] && myconfargs+=( --force-target=generic-gnu )
+
# Build with correct toolchain.
tc-export CC CXX AR NM
# Link with gcc by default, the build system should override this if needed.