summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-07-29 11:35:05 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-07-29 14:17:46 +0200
commit424228c59be974834cc3b93ab6a413aedc8ae8c4 (patch)
tree4f7b4d02fe020fcf23fa2f425c6a3e6ec3d50fae
parentsys-libs/tdb: Bump to version 1.3.10 (diff)
downloadgentoo-424228c59be974834cc3b93ab6a413aedc8ae8c4.tar.gz
gentoo-424228c59be974834cc3b93ab6a413aedc8ae8c4.tar.bz2
gentoo-424228c59be974834cc3b93ab6a413aedc8ae8c4.zip
sys-libs/talloc: Bump to version 2.1.8
Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-libs/talloc/Manifest1
-rw-r--r--sys-libs/talloc/talloc-2.1.8.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/sys-libs/talloc/Manifest b/sys-libs/talloc/Manifest
index b876495db8ff..938779800a63 100644
--- a/sys-libs/talloc/Manifest
+++ b/sys-libs/talloc/Manifest
@@ -1,3 +1,4 @@
DIST talloc-2.1.5.tar.gz 436193 SHA256 3833e750cf0b8c3439186cba38800cba9e26adfbce10ee98ba709c24eb1cdddd SHA512 b938d67fcf4c6618f1149b4ec665957a604e3b07ee26e96ed36d94312db8f56b50498f69f9a07782f7f10a25047604e32b0d1786e1051d5f36b696c2755f8741 WHIRLPOOL 4cbdd527fb1adfe09052b93b38227f6e01f8aa86920aa093b7aa9a0ca63ad03f1ddcc148c996c487c55b1ba6e681b185d1df0311ed388ef9a8e6ab35c4b111ab
DIST talloc-2.1.6.tar.gz 436983 SHA256 3b8e1a50bacb359d99942e0dd9941cef779ae4b5eb20f138873bd8270cb1d47b SHA512 d872780d7ea13757ddb5640c0de5d5c013a9669d07820e9f95b32c460854a4d9327501816a210f33db434b69218a266a6532d5b89fcb6ca84ede90908e3f95c6 WHIRLPOOL 875424e1f84fe28d14b9272758f751ca4c75a38c4fab728f5f8beb1f35052c4f8abfa2a67856120136ea8f9b78d58339e9114f16998c710dfec919b43fe320aa
DIST talloc-2.1.7.tar.gz 437091 SHA256 19154e728e48d29c7398f470b0a59d093edc836156b41ffe20d247d6ec9fa006 SHA512 338353c11ba572edece25d34a00dad3507e8c92670ed2e015e1907662a24143926ccc4b20689f61b2c80bfc8580f6ea17f3eb923cc503ea93fdf034cca3a7d88 WHIRLPOOL 68a433ac908241f834f2c6ffc3828f693c8f252be2b3630bc9fe3b17945e60aa03515b7a2a6018bb286f14fec1894f9db62df2a31b7e37de8aa31afc9c726cfb
+DIST talloc-2.1.8.tar.gz 438490 SHA256 22d14911164d4de67ff76b5269fa5250d01f78c955bc77e28615350996877130 SHA512 8e905c369c74387de21e8d3126cda322a4df2bdb056d3a404de20587e009f63eb16ac673976b43dd399838609aabfea49c38f628adebed19ae7362ed4f0cd121 WHIRLPOOL 7b3b64ef93067d67ec0d4b110aa404c49017c78ac62b644580621f368ad82aed057039d62e03c5a9ae7776ac40d46e1d89f83dc7f7584d48f469a50ee79d98aa
diff --git a/sys-libs/talloc/talloc-2.1.8.ebuild b/sys-libs/talloc/talloc-2.1.8.ebuild
new file mode 100644
index 000000000000..ed4832eaec1b
--- /dev/null
+++ b/sys-libs/talloc/talloc-2.1.8.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit waf-utils python-single-r1 multilib multilib-minimal
+
+DESCRIPTION="Samba talloc library"
+HOMEPAGE="http://talloc.samba.org/"
+SRC_URI="http://samba.org/ftp/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3+ LGPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~sparc-solaris"
+IUSE="compat +python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ !!<sys-libs/talloc-2.0.5
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r1
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-libs/libxslt
+ ${PYTHON_DEPS}"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+RESTRICT="test"
+
+MULTILIB_WRAPPED_HEADERS=(
+ # python goes only for native
+ /usr/include/pytalloc.h
+)
+
+pkg_setup() {
+ # try to turn off distcc and ccache for people that have a problem with it
+ export DISTCC_DISABLE=1
+ export CCACHE_DISABLE=1
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # what would you expect of waf? i won't even waste time trying.
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+
+ use compat && extra_opts+=( --enable-talloc-compat1 )
+ if ! multilib_is_native_abi || ! use python; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure \
+ "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ waf-utils_src_compile
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+
+ # waf is stupid, and no, we can't fix the build-system, since it's provided
+ # as a brilliant binary blob thats decompressed on the fly
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
+ "${ED}"/usr/$(get_libdir)/libtalloc.2.0.5.dylib || die
+ if use python ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libpytalloc-util.2.dylib \
+ "${ED}"/usr/$(get_libdir)/libpytalloc-util.2.0.5.dylib || die
+ install_name_tool \
+ -change "${S}/bin/default/libtalloc.dylib" \
+ "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
+ "${ED}"/usr/$(get_libdir)/libpytalloc-util.2.0.5.dylib || die
+ install_name_tool \
+ -change "${S}/bin/default/libtalloc.dylib" \
+ "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
+ "${D}"$(python_get_sitedir)/talloc.bundle || die
+ fi
+ fi
+}