summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2024-01-27 16:01:47 +1000
committerSam James <sam@gentoo.org>2024-01-27 07:32:03 +0000
commit424a28500ea05c263d4ee2f1536e8eab06b67529 (patch)
treef616d81eb3bd1479e6595bb22ada4ca89b235070
parentdev-build/gn: add 0.2143 (diff)
downloadgentoo-424a28500ea05c263d4ee2f1536e8eab06b67529.tar.gz
gentoo-424a28500ea05c263d4ee2f1536e8eab06b67529.tar.bz2
gentoo-424a28500ea05c263d4ee2f1536e8eab06b67529.zip
dev-build/gn: drop 0.2049
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-build/gn/Manifest1
-rw-r--r--dev-build/gn/gn-0.2049.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-build/gn/Manifest b/dev-build/gn/Manifest
index 7573d37558ea..4efab70868b6 100644
--- a/dev-build/gn/Manifest
+++ b/dev-build/gn/Manifest
@@ -1,4 +1,3 @@
-DIST gn-0.2049.tar.xz 727960 BLAKE2B fe93d09c1fa5b6267a4d26f37ec42e629b36645ef58bf6ebcc07dd8cd2ee9509c1e997182251a3e2c3ef3c5b7d636c9a8228c1e49d1d7245b3ebdac36e7c5a1a SHA512 f3e6dc87d647702c5d22793e2eed3e9950f8c9a6d7178eae67bb7d6518b6533c74fa3f43245fb9e422994a27f1a0f1986709f91e7ce2ed78eb5f17838f75e1db
DIST gn-0.2077.tar.xz 735596 BLAKE2B 48da6c1b08746d364974c94a8395708ba44f4fb88a4bd6142d8ce3935608538b3e3d316c1b3934b124bb2af8549e0bc355b4f0990ab0b794adca025a4c3db7c5 SHA512 361fa1d71f4c4ed12fec8136fb79ee8d30cd8c9b93f2d9972222e028a8b74326045f000431863c6d7ab598b1d7b06c00c95793830da48f52e623a1246bcc8bc4
DIST gn-0.2088.tar.xz 736408 BLAKE2B 23cb932c6fa1711472e0369b5c9271dd28b1d1a8eee40366295ea576fb0d913f3e01dd802df718d6d55ad27b566b0fae5da0cb03167e38df46bbda284b26f99c SHA512 be1d0a0095a7de9fc130935d45c610ab77dd9451822b33c344ac79d096828752bab04b81183eaa35b654abbb76748ce13751c04d44968d08643b6cd89f3fe8f7
DIST gn-0.2114.tar.xz 740080 BLAKE2B 51c6d373ed7a33673e76fe8bb40f727193c6e1172fba328916fd2229d1e350cea5c51da734edf6dbf4c0b7bed61a590424484d4150e7cd4c890abba7f43251c7 SHA512 f5370e45bc2a079b79e4bcfc802fbc6cf67f7674a11311f849699f54775593e75def15323843ef887231891cb06b043863c79c5168e565319a4b73fcffa13738
diff --git a/dev-build/gn/gn-0.2049.ebuild b/dev-build/gn/gn-0.2049.ebuild
deleted file mode 100644
index b390df9895f5..000000000000
--- a/dev-build/gn/gn-0.2049.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 2018-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-PYTHON_COMPAT=( python3_10 )
-
-inherit ninja-utils python-any-r1 toolchain-funcs
-
-DESCRIPTION="GN is a meta-build system that generates build files for Ninja"
-HOMEPAGE="https://gn.googlesource.com/"
-SRC_URI="https://dev.gentoo.org/~xen0n/distfiles/dev-build/gn/${P}.tar.xz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~loong ~ppc64 ~riscv x86"
-IUSE="vim-syntax"
-
-BDEPEND="
- ${PYTHON_DEPS}
- app-alternatives/ninja
-"
-
-PATCHES=(
- "${FILESDIR}"/gn-gen-r5.patch
-)
-
-pkg_setup() {
- :
-}
-
-src_configure() {
- python_setup
- tc-export AR CC CXX
- unset CFLAGS
- set -- ${EPYTHON} build/gen.py --no-last-commit-position --no-strip --no-static-libstdc++ --allow-warnings
- echo "$@" >&2
- "$@" || die
- cat >out/last_commit_position.h <<-EOF || die
- #ifndef OUT_LAST_COMMIT_POSITION_H_
- #define OUT_LAST_COMMIT_POSITION_H_
- #define LAST_COMMIT_POSITION_NUM ${PV##0.}
- #define LAST_COMMIT_POSITION "${PV}"
- #endif // OUT_LAST_COMMIT_POSITION_H_
- EOF
-}
-
-src_compile() {
- eninja -C out gn
-}
-
-src_test() {
- eninja -C out gn_unittests
- out/gn_unittests || die
-}
-
-src_install() {
- dobin out/gn
- einstalldocs
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r misc/vim/{autoload,ftdetect,ftplugin,syntax}
- fi
-}