summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-28 14:59:31 +0000
committerSam James <sam@gentoo.org>2022-12-28 14:59:59 +0000
commit424a3dba4f17ba746122b3dc5ac9b72e5a46151a (patch)
treea71714409a9e72dab803ac05a2a0696ae542cd3c
parentmail-filter/spamassassin: Keyword 4.0.0 riscv, #888119 (diff)
downloadgentoo-424a3dba4f17ba746122b3dc5ac9b72e5a46151a.tar.gz
gentoo-424a3dba4f17ba746122b3dc5ac9b72e5a46151a.tar.bz2
gentoo-424a3dba4f17ba746122b3dc5ac9b72e5a46151a.zip
net-dns/nsd: drop 4.5.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-dns/nsd/Manifest1
-rw-r--r--net-dns/nsd/metadata.xml2
-rw-r--r--net-dns/nsd/nsd-4.5.0.ebuild119
3 files changed, 0 insertions, 122 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index 3e2730dac9d8..19af23ce2df2 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -1,2 +1 @@
-DIST nsd-4.5.0.tar.gz 1259059 BLAKE2B 5c90a17b2c2df3cf06bea2609fb02198b4fdde3e9ed7cc0a07526d43069f735458a0c1775fc7b45ac7bd1fba42ec329fe5b67378d6282bf86f6c520f73b00397 SHA512 0309e1ff083b6f2118ba6fd59425319c21f31558d30e17a40eb8f1e53dee9e3e766d7b53eb50462130ba17b454a3559dc786d344cb779468d255732bbc6bc5da
DIST nsd-4.6.1.tar.gz 1281583 BLAKE2B 5eff5560ce16451a57905bb9d979c81918b6b55f72e1f1b89ab8d2e479ac36bf4f95152c77b1f1b3ce0af90bde8f25d2cad7226450c5cbc879f112adea2b3a69 SHA512 cab557a20cf8564cbf6e38405ca28b00baa6e14105527c3b16f49f57fed5e39cdb2bcd62999bad4aff2c69e0967bdba66a1eaa7b73a0d4d99d97535cc5860bfe
diff --git a/net-dns/nsd/metadata.xml b/net-dns/nsd/metadata.xml
index f4238fbfaaf3..73010eb2f935 100644
--- a/net-dns/nsd/metadata.xml
+++ b/net-dns/nsd/metadata.xml
@@ -14,8 +14,6 @@
<flag name="ratelimit">Enables ratelimiting, based on query name,
type and source</flag>
<flag name="root-server">Configure NSD as a root server</flag>
- <flag name="runtime-checks">Enable runtime checks, this could lead
- to a reduced service level</flag>
<flag name="munin">
Install a plugin for <pkg>net-analyzer/munin</pkg> to graph
statistical data from nsd.</flag>
diff --git a/net-dns/nsd/nsd-4.5.0.ebuild b/net-dns/nsd/nsd-4.5.0.ebuild
deleted file mode 100644
index 4f654418871a..000000000000
--- a/net-dns/nsd/nsd-4.5.0.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools systemd
-
-DESCRIPTION="An authoritative only, high performance, open source name server"
-HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
-LICENSE="BSD"
-SLOT="0"
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/NLnetLabs/nsd.git"
-else
- # version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
- MY_PV="${PV/_beta/b}"
- MY_PV="${MY_PV/_rc/rc}"
- MY_P="${PN}-${MY_PV}"
-
- [[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
- KEYWORDS="amd64 x86"
- SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
- S="${WORKDIR}/${MY_P}"
-fi
-IUSE="bind8-stats dnstap ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl systemd"
-
-RDEPEND="
- acct-group/nsd
- acct-user/nsd
- dnstap? (
- dev-libs/fstrm
- dev-libs/protobuf-c
- )
- libevent? ( dev-libs/libevent )
- munin? ( net-analyzer/munin )
- ssl? ( dev-libs/openssl:0= )
- systemd? ( sys-apps/systemd )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-devel/flex
- app-alternatives/yacc
- systemd? ( virtual/pkgconfig )
-"
-
-PATCHES=(
- # Fix the paths in the munin plugin to match our install
- "${FILESDIR}"/nsd_munin_.patch
-)
-
-src_prepare() {
- default
- # Required to get correct pkg-config macros with USE="systemd"
- # see bugs #663618 and #758050
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-largefile
- --enable-pie
- --enable-relro-now
- --enable-tcp-fastopen
- --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
- --with-logfile="${EPREFIX}"/var/log/nsd.log
- --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
- --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
- --with-xfrdir="${EPREFIX}"/var/db/nsd
- --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
- --with-zonesdir="${EPREFIX}"/var/lib/nsd
- $(use_enable bind8-stats)
- $(use_enable bind8-stats zone-stats)
- $(use_enable dnstap)
- $(use_enable ipv6)
- $(use_enable minimal-responses)
- $(use_enable mmap)
- $(use_enable nsec3)
- $(use_enable ratelimit)
- $(use_enable root-server)
- $(use_enable runtime-checks checking)
- $(use_enable systemd)
- $(use_with libevent)
- $(use_with ssl)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
-
- newinitd "${FILESDIR}"/nsd.initd-r1 nsd
-
- # install munin plugin and config
- if use munin ; then
- exeinto /usr/libexec/munin/plugins
- doexe contrib/nsd_munin_
- insinto /etc/munin/plugin-conf.d
- newins "${FILESDIR}"/nsd.munin-conf nsd_munin
- fi
-
- systemd_dounit "${FILESDIR}"/nsd.service
-
- # remove the /run directory that usually resides on tmpfs and is
- # being taken care of by the nsd init script anyway (checkpath)
- rm -r "${ED}"/run || die "Failed to remove /run"
-
- keepdir /var/db/${PN}
-}
-
-pkg_postinst() {
- # database directory, writable by nsd for database updates and zone transfers
- install -d -m 750 -o nsd -g nsd "${EROOT}"/var/db/nsd
-
- # zones directory, writable by nsd for zone file updates (nsd-control write)
- install -d -m 750 -o nsd -g nsd "${EROOT}"/var/lib/nsd
-}