summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-26 21:59:00 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-26 23:57:50 -0800
commit4268dbe41150641bc96314f17c6453430817942e (patch)
tree3efe1fcb8a20ef2b23d3dad613c74edee1f20480
parentvirtual/python-greenlet-1.0-r1: revbump, move to EAPI=7, python 3.8 (diff)
downloadgentoo-4268dbe4.tar.gz
gentoo-4268dbe4.tar.bz2
gentoo-4268dbe4.zip
dev-python/monotonic-1.5-r1: revbump, EAPI=7, py38, pypy3
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/monotonic/monotonic-1.5-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/monotonic/monotonic-1.5-r1.ebuild b/dev-python/monotonic/monotonic-1.5-r1.ebuild
new file mode 100644
index 000000000000..28cdf82472cc
--- /dev/null
+++ b/dev-python/monotonic/monotonic-1.5-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of time.monotonic() for Python 2 & < 3.3"
+HOMEPAGE="https://github.com/atdt/monotonic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# no tests