summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-04-02 14:52:04 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-04-02 14:52:58 -0400
commit427bb38ba9b9980affd2ec8d07553062334b3614 (patch)
treef7e84fe706ae19717d4cc1d1979009a9b695fe56
parentprofiles/package.mask: mask dev-lang/go-bootstrap for removal (diff)
downloadgentoo-427bb38ba9b9980affd2ec8d07553062334b3614.tar.gz
gentoo-427bb38ba9b9980affd2ec8d07553062334b3614.tar.bz2
gentoo-427bb38ba9b9980affd2ec8d07553062334b3614.zip
games-fps/urbanterror: fix building when USE=-curl is specified (bug #572074)
Package-Manager: portage-2.2.26
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch16
-rw-r--r--games-fps/urbanterror/urbanterror-4.2.023.ebuild4
2 files changed, 19 insertions, 1 deletions
diff --git a/games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch b/games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch
new file mode 100644
index 000000000000..b7d1f3106420
--- /dev/null
+++ b/games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch
@@ -0,0 +1,16 @@
+fix building when USE=-curl is specified (bug #572074)
+
+--- ./code/client/cl_main.c.orig
++++ ./code/client/cl_main.c
+@@ -1872,7 +1872,11 @@
+ }
+
+ qboolean CL_IsDownloading(void) {
++#if USE_CURL
+ return clc.cURLUsed;
++#else
++ return qfalse;
++#endif
+ }
+
+ /*
diff --git a/games-fps/urbanterror/urbanterror-4.2.023.ebuild b/games-fps/urbanterror/urbanterror-4.2.023.ebuild
index a28e710fcacb..606505305f07 100644
--- a/games-fps/urbanterror/urbanterror-4.2.023.ebuild
+++ b/games-fps/urbanterror/urbanterror-4.2.023.ebuild
@@ -81,7 +81,9 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-${ENGINE_PV}-build.patch
+ epatch \
+ "${FILESDIR}"/${PN}-${ENGINE_PV}-build.patch \
+ "${FILESDIR}"/${PN}-${ENGINE_PV}-nocurl.patch
}
src_compile() {