summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-18 22:16:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-18 23:28:17 +0100
commit427e95d435eecf60aa139fafc4dd1b2a13820f20 (patch)
treeb2deff3fdacf131c8a14986e9f92d5bc26fab916
parentdev-python/pytest-subtests: Remove old (diff)
downloadgentoo-427e95d435eecf60aa139fafc4dd1b2a13820f20.tar.gz
gentoo-427e95d435eecf60aa139fafc4dd1b2a13820f20.tar.bz2
gentoo-427e95d435eecf60aa139fafc4dd1b2a13820f20.zip
dev-python/pyscard: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyscard/Manifest1
-rw-r--r--dev-python/pyscard/pyscard-2.0.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index bec2780437f0..b0dbedaa2c86 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1 +1,2 @@
DIST pyscard-2.0.2.tar.gz 149302 BLAKE2B bb1203aea42a0caca5212780f1312e51a4cf1a2b2842e3e33f25c17e57e3400d44c387620ec4a1dc9ca7a4ef5747900981971c87d1e37b6523a5990362645f5a SHA512 f6ab42a0aa037189f2fefe4001dde7f49125fdf63358352af956e58da9a51744a884ff1f7173b71e035a1a4a20825a906ee5d94f314b760333d1110c898a6644
+DIST pyscard-2.0.3.tar.gz 150092 BLAKE2B af7d58266044792987e6f9a2bc708ca043e32c4f87c8622b5662449254e7d6b630d5769479f3eaf59dc9a3a9fa294330953dea3383aee6c216f3d7dcfd26266a SHA512 2f5c762fe4a7d8d3292f335fda58f8f2f88729ea6d33a508e5f461692fef8d006ccc9b761a78750b8416dc5c1f7c6b06c069e3f6e7b19d91621226590bfef708
diff --git a/dev-python/pyscard/pyscard-2.0.3.ebuild b/dev-python/pyscard/pyscard-2.0.3.ebuild
new file mode 100644
index 000000000000..2eefa09fd4bc
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/swig"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}
+
+python_test() {
+ cd test || die
+ eunittest
+}