summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-09 03:58:30 +0100
committerSam James <sam@gentoo.org>2021-10-09 03:58:50 +0100
commit428ddb674f51260ca29fe5ff29af2d1260a7ed59 (patch)
treec33ed070fa4dc3623799ec11292984ee25dd73c6
parentnet-mail/cyrus-imapd: build tests conditionally (diff)
downloadgentoo-428ddb67.tar.gz
gentoo-428ddb67.tar.bz2
gentoo-428ddb67.zip
app-editors/vim: fix automagic libsodium dependency
Closes: https://bugs.gentoo.org/816966 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/vim/metadata.xml1
-rw-r--r--app-editors/vim/vim-8.2.3428-r1.ebuild (renamed from app-editors/vim/vim-8.2.3428.ebuild)4
-rw-r--r--app-editors/vim/vim-9999.ebuild4
3 files changed, 7 insertions, 2 deletions
diff --git a/app-editors/vim/metadata.xml b/app-editors/vim/metadata.xml
index cd2ce2b6d09e..4f3a37faf97f 100644
--- a/app-editors/vim/metadata.xml
+++ b/app-editors/vim/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Vim Project</name>
</maintainer>
<use>
+ <flag name="crypt">Use <pkg>dev-libs/libsodium</pkg> for crypto support</flag>
<flag name="cscope">Enable cscope interface</flag>
<flag name="ipv6">Enable IPv6 support in channel</flag>
<flag name="racket">Enable support for Scheme using <pkg>dev-scheme/racket</pkg></flag>
diff --git a/app-editors/vim/vim-8.2.3428.ebuild b/app-editors/vim/vim-8.2.3428-r1.ebuild
index fd00866b78b5..d15fa2f9dcc8 100644
--- a/app-editors/vim/vim-8.2.3428.ebuild
+++ b/app-editors/vim/vim-8.2.3428-r1.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
SLOT="0"
LICENSE="vim"
-IUSE="X acl cscope debug gpm lua minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
+IUSE="X acl crypt cscope debug gpm lua minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -36,6 +36,7 @@ RDEPEND="
>=sys-libs/ncurses-5.2-r2:0=
nls? ( virtual/libintl )
acl? ( kernel_linux? ( sys-apps/acl ) )
+ crypt? ( dev-libs/libsodium:= )
cscope? ( dev-util/cscope )
gpm? ( >=sys-libs/gpm-1.19.3 )
lua? ( ${LUA_DEPS}
@@ -200,6 +201,7 @@ src_configure() {
--with-features=huge
$(use_enable sound canberra)
$(use_enable acl)
+ $(use_enable crypt libsodium)
$(use_enable cscope)
$(use_enable gpm)
$(use_enable nls)
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index fd00866b78b5..d15fa2f9dcc8 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
SLOT="0"
LICENSE="vim"
-IUSE="X acl cscope debug gpm lua minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
+IUSE="X acl crypt cscope debug gpm lua minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -36,6 +36,7 @@ RDEPEND="
>=sys-libs/ncurses-5.2-r2:0=
nls? ( virtual/libintl )
acl? ( kernel_linux? ( sys-apps/acl ) )
+ crypt? ( dev-libs/libsodium:= )
cscope? ( dev-util/cscope )
gpm? ( >=sys-libs/gpm-1.19.3 )
lua? ( ${LUA_DEPS}
@@ -200,6 +201,7 @@ src_configure() {
--with-features=huge
$(use_enable sound canberra)
$(use_enable acl)
+ $(use_enable crypt libsodium)
$(use_enable cscope)
$(use_enable gpm)
$(use_enable nls)