summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-29 08:32:45 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-29 08:32:45 +1200
commit429a99709cf618fac752652d2871fdcfab8b1f99 (patch)
treec2cef6fe40d287ed4e0966e8c9cf31c96bc457b7
parentvirtual/perl-libnet: PDEPEND dev-perl/IO-Socket-SSL re bug #735004 (diff)
downloadgentoo-429a9970.tar.gz
gentoo-429a9970.tar.bz2
gentoo-429a9970.zip
dev-perl/DateTime-Locale: Bump to version 1.270.0
Upstream: - Return value of $locale->locale_data now deeply cloned to allow data modification without breaking the original locale - Support loading loading locale data from relative directories in @INC - Check $! for read errors loading locales on top of just checking eval compiled ok. Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/DateTime-Locale/DateTime-Locale-1.270.0.ebuild49
-rw-r--r--dev-perl/DateTime-Locale/Manifest1
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Locale/DateTime-Locale-1.270.0.ebuild b/dev-perl/DateTime-Locale/DateTime-Locale-1.270.0.ebuild
new file mode 100644
index 000000000000..325edf9be2b8
--- /dev/null
+++ b/dev-perl/DateTime-Locale/DateTime-Locale-1.270.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=1.27
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="Localization support for DateTime"
+
+LICENSE="|| ( Artistic GPL-1+ ) unicode"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ virtual/perl-Exporter
+ dev-perl/File-ShareDir
+ virtual/perl-File-Spec
+ >=dev-perl/Params-ValidationCompiler-0.130.0
+ >=virtual/perl-Scalar-List-Utils-1.450.0
+ >=dev-perl/Specio-0.150.0
+ virtual/perl-Storable
+ >=dev-perl/namespace-autoclean-0.190.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/File-ShareDir-Install-0.60.0
+ test? (
+ virtual/perl-CPAN-Meta-Requirements
+ >=dev-perl/CPAN-Meta-Check-0.11.0
+ virtual/perl-File-Temp
+ dev-perl/IPC-System-Simple
+ dev-perl/Path-Tiny
+ dev-perl/Test-File-ShareDir
+ >=virtual/perl-Test-Simple-1.302.15
+ dev-perl/Test2-Plugin-NoWarnings
+ dev-perl/Test2-Suite
+ )
+"
+PERL_RM_FILES=(
+ # https://github.com/houseabsolute/DateTime-Locale/issues/27
+ t/nonexistent-locale.t
+)
diff --git a/dev-perl/DateTime-Locale/Manifest b/dev-perl/DateTime-Locale/Manifest
index 93a6fcc31fd6..09befaa40480 100644
--- a/dev-perl/DateTime-Locale/Manifest
+++ b/dev-perl/DateTime-Locale/Manifest
@@ -4,3 +4,4 @@ DIST DateTime-Locale-1.03.tar.gz 959190 BLAKE2B 025075d0606c83afacc0b21309068b23
DIST DateTime-Locale-1.05.tar.gz 959564 BLAKE2B 14ce7e84922d3897829c464e6fff864088a6570afeb2a104802d55468845f8bcd3650b7267216a7c2c6e5337ee2b993175341dd5c8fc5589600b0671a9e220eb SHA512 8e5484e20ccd6f21343dd8eed708f4ec70a0a11f86b83d4a304ebc01b6f8a613d8b08b3a51cf520eeac7730720a996ef36b5e93e771f5fd03f92e283e4ff1f94
DIST DateTime-Locale-1.16.tar.gz 1228443 BLAKE2B 43b9bc0439d269dd29856538c87ff866337dc989b85d7e677e62ececf93a194b65cfb99eae07c17a97e8d7c2c917cf533e751856e09c1d63684c70de99aac4a9 SHA512 66b09f2f2d9cbb9ed969c6e881dd68a48957d69d5d4cd8a998b7a79538050807d862813eae677ef28ec2ce645c8fc15b9b5de2b15ed077e936d63a44e072a145
DIST DateTime-Locale-1.26.tar.gz 1389665 BLAKE2B 65423f466472f25de7fd82379183d422a1bb3fbde59defe3a46aeb5d3b3a4806866365af4998a424c0e734ed7072b4f7a3619d07355fba9b681740d389f3f58d SHA512 2b664f931abf4c81b6ff80752b3eb03c7d71aa6cd11da0e925a157ea0838234bc1ccb243ddd129d65f7f47e5e739176591bfe1c7ed2ec4d1476e56bdbe66c1b1
+DIST DateTime-Locale-1.27.tar.gz 1390926 BLAKE2B bb23a61d5649a613028c743e7215e3245786c3a07a6eba4d525451a81deb0755aff6824a91626e74657213fc9b51b5ce685683a941552f3b305a69d60fcc14b9 SHA512 31db31b08535c9d939223475786c85da4eb91ed2de2355b3b7e052603c6ed17c7ee5efb17952aa7868c3e1a25afb2d1c99241e2ff277584e8aa29a538e14ffce