summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-07 09:58:40 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-07 09:58:40 -0400
commit42a0f06960a3e1c51c6b3a8841c20118d5c2753c (patch)
treef19b87c246b33ab7a00121a7be9fc3b8dc3426e1
parentsys-kernel/gentoo-sources: 4.19.37 stable on sparc (diff)
downloadgentoo-42a0f069.tar.gz
gentoo-42a0f069.tar.bz2
gentoo-42a0f069.zip
dev-libs/libutf8proc: fix build on Prefix
Closes: https://bugs.gentoo.org/685266 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch2
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.3.0-r1.ebuild (renamed from dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild)9
2 files changed, 9 insertions, 2 deletions
diff --git a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch
index 5750b43ad5fc..f438fdd9779b 100644
--- a/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch
+++ b/dev-libs/libutf8proc/files/libutf8proc-2.3.0-tests-nofetch.patch
@@ -6,7 +6,7 @@ index f5d1dd9..60c09e3 100644
MAKE=make
JULIA=julia
CURLFLAGS = --retry 5 --location
-+UDATA=/usr/share/unicode-data
++UDATA=${EPREFIX}/usr/share/unicode-data
.PHONY: clean
diff --git a/dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild b/dev-libs/libutf8proc/libutf8proc-2.3.0-r1.ebuild
index 3b3b3a532031..3d5231b82df9 100644
--- a/dev-libs/libutf8proc/libutf8proc-2.3.0.ebuild
+++ b/dev-libs/libutf8proc/libutf8proc-2.3.0-r1.ebuild
@@ -26,8 +26,15 @@ PATCHES=(
"${FILESDIR}/${PN}-2.3.0-tests-nofetch.patch"
)
+src_compile() {
+ emake CC=$(tc-getCC) AR=$(tc-getAR)
+}
+
src_install() {
- emake DESTDIR="${D}" prefix=/usr libdir=/usr/$(get_libdir) install
+ emake DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ libdir="${EPREFIX}/usr/$(get_libdir)" \
+ install
# This package used to use netsurf's version as an upstream, which lives in
# its own little world. Unlike julia's version, it puts its header file
# in libutf8proc/utf8proc.h instead of utf8proc.h. The problem is that