summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-08 06:28:14 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-08 07:34:46 +0200
commit42c145c031e395a78a266689f9e1c50e6e189b7f (patch)
tree39f0d6e4e3299d500002422f6e08a3388fba14af
parentdev-python/google-auth: Bump to 2.7.0 (diff)
downloadgentoo-42c145c0.tar.gz
gentoo-42c145c0.tar.bz2
gentoo-42c145c0.zip
dev-python/python-magic: Bump to 0.4.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-magic/Manifest1
-rw-r--r--dev-python/python-magic/python-magic-0.4.27.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-magic/Manifest b/dev-python/python-magic/Manifest
index 1acd33f3a408..9a0d172a3fbc 100644
--- a/dev-python/python-magic/Manifest
+++ b/dev-python/python-magic/Manifest
@@ -1,2 +1,3 @@
DIST python-magic-0.4.25.gh.tar.gz 864121 BLAKE2B ec79112aba9f79a6dd6a3840a1286432806c0cd035d301668fd8177ce36b270ddf1c928f70d51cfacb88cca4d5fb31706cff946b16ed230e8850bca9ebda8c0b SHA512 eb138f7f2d1320f831516fdf21bf7dd404acf070be6093b7ed8697325f60998d886405c5ff348c7e4ad69ecd2ee0ab899afe455db90eda502acdf8b86337f79c
DIST python-magic-0.4.26.gh.tar.gz 863618 BLAKE2B 62d85758402d77376e685eb0f8964fd5d9e2a62775c3566d7f2a76284b287b6b17f9f759dbc08404087fc8a524609cefa65ab8e74020c4bd4f49e8ae3a2d604f SHA512 a9f2f8ef9f1aef9e9455b656fabf8e6cf7b1a9df4af2012c7a9426e0740cd6e8952e6957e01710809ab018d008fd531a74e9f66640af1299b61c35ede590b749
+DIST python-magic-0.4.27.gh.tar.gz 863649 BLAKE2B 4ba22d0f8bd5e70eb37e3b46eba1b885d49682bf45d703ad7966bcc67614427ebe597e3100575f863b7e54421c6de6fc875af24a9d5b49742fe07b361b65f198 SHA512 a476730a5caa9a2a784187f57743d5cec4b1829a6a76d4d1fb4e0112caf5487888961df293bc38074ef1a5d313b0fc4aed4cc99b980f5336e8a907c44a33e84e
diff --git a/dev-python/python-magic/python-magic-0.4.27.ebuild b/dev-python/python-magic/python-magic-0.4.27.ebuild
new file mode 100644
index 000000000000..c795f460395f
--- /dev/null
+++ b/dev-python/python-magic/python-magic-0.4.27.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Access the libmagic file type identification library"
+HOMEPAGE="
+ https://github.com/ahupp/python-magic/
+ https://pypi.org/project/python-magic/
+"
+SRC_URI="
+ https://github.com/ahupp/python-magic/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+
+RDEPEND="
+ sys-apps/file[-python]
+"
+BDEPEND="
+ test? (
+ sys-apps/file
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ local -x LC_ALL=en_US.UTF-8
+ eunittest -p "*_test.py"
+}