summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:08:20 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:49 +0100
commit42e3aa8183ff851719925f45f287e2ef828c3586 (patch)
tree4244cf16b3e29a8f5a0a9435b134620b81477fe2
parentdev-haskell/invariant: add 0.6.2 (diff)
downloadgentoo-42e3aa8183ff851719925f45f287e2ef828c3586.tar.gz
gentoo-42e3aa8183ff851719925f45f287e2ef828c3586.tar.bz2
gentoo-42e3aa8183ff851719925f45f287e2ef828c3586.zip
dev-haskell/iproute: add 1.7.12
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/iproute/Manifest1
-rw-r--r--dev-haskell/iproute/files/iproute-1.7.12-package-imports.patch20
-rw-r--r--dev-haskell/iproute/iproute-1.7.12.ebuild32
-rw-r--r--dev-haskell/iproute/metadata.xml7
4 files changed, 53 insertions, 7 deletions
diff --git a/dev-haskell/iproute/Manifest b/dev-haskell/iproute/Manifest
index 1c138c30e702..834c1a541f79 100644
--- a/dev-haskell/iproute/Manifest
+++ b/dev-haskell/iproute/Manifest
@@ -1 +1,2 @@
+DIST iproute-1.7.12.tar.gz 17864 BLAKE2B ac69d90c43415602f52d69de69d3c044cf1908eeadb60266ccc629f8589e53a6cae27a32ad990595f65055f97fd597ca81eda83d34f909d8a0ee1f151edf6d0b SHA512 45d60e98e0a18929472d3de8850a257e21a638b3052fc31afc960c0ea755092bf44e44a1b0fae175582c1bcbda6029af028e84ba1498fe6491d925173cf310b7
DIST iproute-1.7.8.tar.gz 13309 BLAKE2B 8d6bef341643e4f096399fcba595e339d63b056aca086434fdbb906688c5720fb556ac17cbaf0c0ff851bd44133e97643a03f35db837065268f0d791222616fa SHA512 ee1bd24a560ee73757ca71eda70a610d5c8e01101c22835bbef23ec7a2217ed66a37b49d5fc3042f3df0e943aaeda2a050e75316ff2ac11602b745cbf7d7ca6a
diff --git a/dev-haskell/iproute/files/iproute-1.7.12-package-imports.patch b/dev-haskell/iproute/files/iproute-1.7.12-package-imports.patch
new file mode 100644
index 000000000000..f7f88a6cedd4
--- /dev/null
+++ b/dev-haskell/iproute/files/iproute-1.7.12-package-imports.patch
@@ -0,0 +1,20 @@
+diff -urN iproute-1.7.12/Data/IP/Addr.hs iproute-1.7.12-r1/Data/IP/Addr.hs
+--- iproute-1.7.12/Data/IP/Addr.hs 2001-09-08 19:46:40.000000000 -0600
++++ iproute-1.7.12-r1/Data/IP/Addr.hs 2022-01-15 10:13:21.758588845 -0700
+@@ -1,6 +1,7 @@
+ {-# LANGUAGE BangPatterns #-}
+ {-# LANGUAGE DeriveDataTypeable #-}
+ {-# LANGUAGE DeriveGeneric #-}
++{-# LANGUAGE PackageImports #-}
+
+ module Data.IP.Addr where
+
+@@ -14,7 +15,7 @@
+ import Data.Word
+ import Network.Socket
+ import Numeric (showHex, showInt)
+-import System.ByteOrder
++import "byteorder" System.ByteOrder
+ import Text.Appar.String
+ import GHC.Enum (succError,predError)
+ import GHC.Generics
diff --git a/dev-haskell/iproute/iproute-1.7.12.ebuild b/dev-haskell/iproute/iproute-1.7.12.ebuild
new file mode 100644
index 000000000000..9d3683101441
--- /dev/null
+++ b/dev-haskell/iproute/iproute-1.7.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="IP Routing Table"
+HOMEPAGE="https://www.mew.org/~kazu/proj/iproute/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+PATCHES=( "${FILESDIR}/${PN}-1.7.12-package-imports.patch" )
+
+RDEPEND="dev-haskell/appar:=[profile?]
+ dev-haskell/byteorder:=[profile?]
+ dev-haskell/network:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/doctest-0.9.3
+ dev-haskell/hspec
+ dev-haskell/quickcheck
+ dev-haskell/safe )
+"
diff --git a/dev-haskell/iproute/metadata.xml b/dev-haskell/iproute/metadata.xml
index 429df5ba18d3..937381521944 100644
--- a/dev-haskell/iproute/metadata.xml
+++ b/dev-haskell/iproute/metadata.xml
@@ -5,11 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- IP Routing Table is a tree of IP ranges
- to search one of them on the longest
- match base. It is a kind of TRIE with one
- way branching removed. Both IPv4 and IPv6
- are supported.
- </longdescription>
</pkgmetadata>