summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-24 15:36:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-24 15:44:40 +0200
commit42e8352f610f571ffe7452edab603fbd64a81c6e (patch)
treeab884a110dbb5a4d5f12610459b1205653e4b865
parentdev-ros/diagnostic_aggregator: Bump to 1.10.1. (diff)
downloadgentoo-42e8352f610f571ffe7452edab603fbd64a81c6e.tar.gz
gentoo-42e8352f610f571ffe7452edab603fbd64a81c6e.tar.bz2
gentoo-42e8352f610f571ffe7452edab603fbd64a81c6e.zip
dev-ros/diagnostic_analysis: Bump to 1.10.1.
Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/diagnostic_analysis/Manifest1
-rw-r--r--dev-ros/diagnostic_analysis/diagnostic_analysis-1.10.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_analysis/Manifest b/dev-ros/diagnostic_analysis/Manifest
index c5f155e4f883..2fd727f3702d 100644
--- a/dev-ros/diagnostic_analysis/Manifest
+++ b/dev-ros/diagnostic_analysis/Manifest
@@ -1,2 +1,3 @@
+DIST diagnostics-1.10.1.tar.gz 536607 BLAKE2B 6a69163fbf60820839f1fc7071b6ea9df7b70cc2979b42648ac56d0acce820af69595b2a9e4d11b9752d4d85bd19276ccfcb6a57a523e7d69354fbc64414fec4 SHA512 a45d41a0ba3b879ab3228bc3d3152cd59d7145b96f9a5b1798eb1d9aaba8dbd6234ec3692c1a84289d0f543eed3adb0ca4dcbd1f1b6ceaef54af7866e1ad9ee7
DIST diagnostics-1.9.4.tar.gz 533933 BLAKE2B 07effeceaa55fd86995a1202777a926c4474e7fe4bba1e013ec5bd6191ed7b39ab6a6e7220d9a48a97c79beec3965ba0bd639e3e56ad64d061730a9a40258e49 SHA512 1438e7b81e74f86a90a8528cf363b94149657f178fba58b532909249c2a9841d4225c0169ff78914ac695acc1494a89b06f0dee145a4b3b00a0c7efaebe0d467
DIST diagnostics-1.9.6.tar.gz 534544 BLAKE2B 25cf7d15033dbb265d5e75d137b344f0a22b63bafb5ecf67d4cc24727ce03f83a0fc040c571e67ec703f155139d158ba415c9005cfc5937cd556b55fd60bc4a4 SHA512 f239504c9920b9c6582f24a322b8bd24c671d6e7dd29f144bf506a051356456e902ddeb0cb122be0dae1d2d3418da33cd5237229bf017695cee48289358bbd4b
diff --git a/dev-ros/diagnostic_analysis/diagnostic_analysis-1.10.1.ebuild b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.10.1.ebuild
new file mode 100644
index 000000000000..fdc2bbe90d68
--- /dev/null
+++ b/dev-ros/diagnostic_analysis/diagnostic_analysis-1.10.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/diagnostics"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Converts diagnostics data into a series of CSV files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]") )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}