summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-23 15:35:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-24 13:07:15 +0200
commit42f51b0a8d169a3c54526556813bd0c749940737 (patch)
treec5ed755db630cadb07264a333a19f2221d211533
parentdev-ros/geneus: Bump to 2.2.6 (diff)
downloadgentoo-42f51b0a8d169a3c54526556813bd0c749940737.tar.gz
gentoo-42f51b0a8d169a3c54526556813bd0c749940737.tar.bz2
gentoo-42f51b0a8d169a3c54526556813bd0c749940737.zip
dev-ml/core: bump to 0.9.1
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--dev-ml/core/Manifest1
-rw-r--r--dev-ml/core/core-0.9.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/core/Manifest b/dev-ml/core/Manifest
index aae420ca2bfa..c948f5ef4d6a 100644
--- a/dev-ml/core/Manifest
+++ b/dev-ml/core/Manifest
@@ -1 +1,2 @@
DIST core-0.9.0.tar.gz 734916 SHA256 3af762b2116225f8544549e81a6ebfd9155f71ba3707eedfa98038aa76bcb4b1 SHA512 733fae8552ddb0842455d625786de4a76979b40bee6503954ff77493bad2d5bad143f39f8091fd3b76562edfd14f2a2c9a4e1ec1a11fcf023aac39308d23083c WHIRLPOOL ebc9e79916dafeac71a412058958a2842ca1346f57c52048c2c1cf2588149df10ae6b130a383bfd844b99fc13fad24f2150006841eee2d36e449f224b2d27190
+DIST core-0.9.1.tar.gz 735006 SHA256 a8d34b76afd8ad5ac525471e7f01d4291203a4b83b9e3051314af13cb169a3ba SHA512 2d4a7ff753cb0415cc6a957fff53037aad65053d3c3531070663b4bcf4462982c811a586a39ea3a223aca02cae9212c300b6788266ac60213437dc99ecc0a29a WHIRLPOOL c6e6a9f2e9f29ad04b5850706f116ae23d2cb26550dc1113653c0c857f9f183a9dc6644121aeff2526ef7fd48a4fadc7b8407d615fe3395cf0f526891aaa6699
diff --git a/dev-ml/core/core-0.9.1.ebuild b/dev-ml/core/core-0.9.1.ebuild
new file mode 100644
index 000000000000..64835cb4c69c
--- /dev/null
+++ b/dev-ml/core/core-0.9.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="https://github.com/janestreet/core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/base:=
+ dev-ml/configurator:=
+ dev-ml/core_kernel:=
+ dev-ml/ppx_assert:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/sexplib:=
+ dev-ml/spawn:=
+ dev-ml/stdio:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}