summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-11 15:46:30 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-01-11 15:46:30 +0100
commit4300cccf187ab49cae1ce97fa1825cf397f4d509 (patch)
treea289694ae4a13d364ea946e9a833cefdcf6fd9e5
parentsci-libs/ipopt: add version 3.14.4 (diff)
downloadgentoo-4300cccf187ab49cae1ce97fa1825cf397f4d509.tar.gz
gentoo-4300cccf187ab49cae1ce97fa1825cf397f4d509.tar.bz2
gentoo-4300cccf187ab49cae1ce97fa1825cf397f4d509.zip
sci-libs/getdata: add version 0.11.0, EAPI bump
Closes: https://bugs.gentoo.org/811978 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-libs/getdata/Manifest1
-rw-r--r--sci-libs/getdata/getdata-0.11.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/getdata/Manifest b/sci-libs/getdata/Manifest
index d5e6e9deacee..90756e50ea07 100644
--- a/sci-libs/getdata/Manifest
+++ b/sci-libs/getdata/Manifest
@@ -1 +1,2 @@
+DIST getdata-0.11.0.tar.xz 1060324 BLAKE2B b758447429f95d53d6ce3e32eb5591d0141c218f5b3a3c391fb713722f8dc12fba2add078d75be1b2957b2d27b7d843cb51450fc49394da130548721f5df9384 SHA512 cf301449288c2b0e337a356f03ac8d295a4f5a32eb6c2a29c15c6fcc434a9eea8661a8070defbbf1d751e64e1f616e4353863b13d350fa8df6837631d86bc932
DIST getdata-0.9.0.tar.xz 920652 BLAKE2B d5f0659474dfab9f4e589a28a7788b5a51de3c0064b58de37bdb11dad27b56daa05d8e705da743c5da271bd8c4e1343ac6ac41adfdfabfcaef0006e46c45d2bf SHA512 28d720141e34cc56a5166594d0a6ac293144d123706988ed170e40dd9d7aaf13b920305e8bd8343ecd7cbe43eee5d83720e3e5f5d2da0cdccdc1444725cc6844
diff --git a/sci-libs/getdata/getdata-0.11.0.ebuild b/sci-libs/getdata/getdata-0.11.0.ebuild
new file mode 100644
index 000000000000..b80fd2fefb1b
--- /dev/null
+++ b/sci-libs/getdata/getdata-0.11.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+FORTRAN_STANDARD="95"
+FORTRAN_NEEDED=fortran
+inherit autotools fortran-2 flag-o-matic
+
+DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
+HOMEPAGE="http://getdata.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 cxx debug flac fortran lzma perl static-libs"
+
+DEPEND="
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ perl? ( dev-lang/perl )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # GCC 10 workaround
+ # bug #723076
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
+ econf \
+ --disable-idl \
+ --disable-matlab \
+ --disable-php \
+ --with-libz \
+ --without-libslim \
+ --without-libzzip \
+ $(use_with bzip2 libbz2) \
+ $(use_enable cxx cplusplus) \
+ $(use_enable debug) \
+ $(use_with flac libFLAC) \
+ $(use_enable fortran) \
+ $(use_enable fortran fortran95) \
+ $(use_with lzma liblzma) \
+ $(use_enable perl) \
+ $(usex perl --with-perl-dir=vendor) \
+ --disable-python \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}